Got this after installing trial

7 posts, 0 answers
  1. Gary Blakely
    Gary Blakely avatar
    63 posts
    Member since:
    Jan 2010

    Posted 21 Jan 2010 Link to this post

    Installed the trial and now I get this error when clicking on the SL icon...
    Can anyone help?
    Gary

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'System.Web.Ria, Version=2.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified. (C:\Program Files (x86)\Telerik\RadControls for Silverlight Q3 2009 SP2\Demos\ExamplesWeb\web.config line 73)

    Source Error:

    Line 71:     <httpModules>
    Line 72:       <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
    Line 73: <add name="DomainServiceModule" type="System.Web.Ria.Services.DomainServiceHttpModule, System.Web.Ria,Version=2.0.0.0,Culture=neutral,PublicKeyToken=31BF3856AD364E35"/>Line 74:     </httpModules>
    Line 75:   </system.web>

    Source File: C:\Program Files (x86)\Telerik\RadControls for Silverlight Q3 2009 SP2\Demos\ExamplesWeb\web.config    Line: 73


    Version Information: Microsoft .NET Framework Version:2.0.50727.4927; ASP.NET Version:2.0.50727.4927
  2. Ron George
    Ron George avatar
    4 posts
    Member since:
    Jan 2010

    Posted 21 Jan 2010 Link to this post

    Hey Gary, the first thing they are going to tell you is to install the WCF RIA Services.

    Its here, http://www.microsoft.com/web/ or you can just do a search at MSFT Downloads.


  3. Gary Blakely
    Gary Blakely avatar
    63 posts
    Member since:
    Jan 2010

    Posted 22 Jan 2010 Link to this post

    RIA Services is still a Beta product, no?
    Gary
  4. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 26 Jan 2010 Link to this post

    Hello Gary Blakely,

    This error is shown then Ria services is not installed on the host machine. Although Ria Services is still in beta phase it has become quite popular and it generated a lot of interest and we decided to include some samples in our QuickStart application.

    The latest release of WCF Ria Services can be downloaded from here.

    Hope this helps.


    All the best,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  5. PM
    PM avatar
    39 posts
    Member since:
    Nov 2009

    Posted 17 Feb 2010 Link to this post

    Hi,

     I downloaded 'Ria Services', when i try to install 'Ria Services' it is asking to install 'Silverlight 3 Developer Runtime' and 'Silverlight 3 tools'. i downloaded 'Silverlight 3 tools from microsoft site' and tried to install it but again while installing  it is required Windows XP Service Pack 3.

    Actually my system OS is "Windows XP Media Center Edition Service Pack 2".

    Please help me regarding this, do i need to install Windows XP Service Pack 3 or is there any other way to run silverlight applications in my system.



  6. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 17 Feb 2010 Link to this post

    Hi Praveen Muthyala,

    I guess you should install Service Pack 3 if it is required by Silverlight Tools.


    Sincerely yours,
    Milan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. PM
    PM avatar
    39 posts
    Member since:
    Nov 2009

    Posted 17 Feb 2010 Link to this post

    Thank you.
Back to Top