get a compile error after install radcontrol silverlight dev

2 posts, 0 answers
  1. j
    j avatar
    8 posts
    Member since:
    May 2009

    Posted 09 Feb 2011 Link to this post

    Hi,

    We just purchase the radcontrol 2010 Q3. after install, the previous worked project got an error.

    Error 10 The "ValidateXaml" task failed unexpectedly.
    System.TypeLoadException: Could not load type 'System.ComponentModel.DefaultPropertyAttribute' from assembly 'System, Version=2.0.5.0, Culture=neutral, PublicKeyToken=7cec85d7bea7798e'.
      

    previous it worked under version 2010 Q1 trial version with visual studio 2008 V9.030729.1 SP .

    And I also checked at Reference Assemblies\Microsoft\Framework\Silverlight\v3.0\system.dll.
    it seems that dll file does not contain System.ComponentModel.DefaultPropertyAttribute. and the close one it contains is System.ComponentModel.DefaultValueAttribute


    Thanks





  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 10 Feb 2011 Link to this post

    Hi,

     Are you trying to compile Silverlight 4 assemblies (our official assemblies are only for Silverlight4) in Silverlight 3 project? 

    All the best,
    Vlad
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
Back to Top