fiddler: connection failed

5 posts, 0 answers
  1. kathy
    kathy avatar
    2 posts
    Member since:
    Jun 2014

    Posted 16 Jun 2014 Link to this post

    I have installed the full version of dot net 4 and fiddler 4 to debug a website on a windows xp pc. But when I open firefox and start fiddler I get the following error in the browser
    [Fiddler] The connection to 'fiddler2.com' failed.
    Error: InvalidArgument (0x2726).
    System.Net.Sockets.SocketException
    An invalid argument was supplied 198.61.131.236:80

    I've followed the documentation on the telerik website and googled for a solution but can't find anything.
    Can anybody help?
  2. Eric Lawrence
    Admin
    Eric Lawrence avatar
    832 posts

    Posted 16 Jun 2014 Link to this post

    Hi, Kathy!

    This error ('WSAEINVAL') is quite unusual. I assume you haven't changed any of the settings inside Tools > Fiddler Options?

    The most likely explanation is that you have Firewall software installed that is blocking Fiddler. Do you have a 3rd party firewall, or are you using the default Firewall that comes with Windows? Have you configured an exception so that Fiddler can interact with the network without blocking?

    Do you have all of the latest updates for your PC installed from WindowsUpdate?

    Regards,
    Eric Lawrence
    Telerik
     

    Check out the Telerik Platform - the only platform that combines a rich set of UI tools with powerful cloud services to develop web, hybrid and native mobile apps.

     
  3. kathy
    kathy avatar
    2 posts
    Member since:
    Jun 2014

    Posted 17 Jun 2014 in reply to Eric Lawrence Link to this post

    Thank you Eric!

    No, I haven't changed any of the settings. Yes, I do use a 3rd party firewall (panda). But I hadn't configured the rules correctly for Fiddler. Now that I have done that, everything is working fine. Thanks  again.

    Well, I like to think that if I'm going to post a question on a forum that it's something 'quite unusual'. At least I succeeded in that! Maybe somebody else will also benefit from this thread.

    Regards,
    Kathy
  4. fee
    fee avatar
    1 posts
    Member since:
    Oct 2017

    Posted 20 Oct in reply to Eric Lawrence Link to this post

    Hi, Eric! 

    I‘m sure there is no prolem with  my firewall, the other connection seems normal,except the damned url.Hope you can see this and answer me!

    Yours sincerely

    Zhongwei Yu

  5. Alexander
    Admin
    Alexander avatar
    196 posts

    Posted 25 Oct Link to this post

    Hello,

    Could you, please, elaborate some more on what is the problem? What are you trying to achieve, which is "the other connection seems normal", which is the URL you are trying to access etc.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top