Error loading RadGridView assembly into Expression Blend 2

14 posts, 0 answers
  1. Hector
    Hector avatar
    92 posts
    Member since:
    May 2009

    Posted 29 May 2009 Link to this post

    I am getting the following error whenn I try to add a RadGridView to my XAML page:

    the located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT:0x80131040)

    Is this a bug, or am I doing something wrong?

    THanks
  2. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 29 May 2009 Link to this post

    Hello Hector,

    Please refer to this blog post - http://www.telerik.com/community/forums/silverlight/gridview/radgrid-manifest-error-on-blend.aspx

    Regards,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  3. Hector
    Hector avatar
    92 posts
    Member since:
    May 2009

    Posted 29 May 2009 Link to this post

    Thank you!  That solved my problem.
    Thanks
  4. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 12 Nov 2009 Link to this post

    Is this still a problem? cos I get an error when trying to use it in BLEND2.
    And the link: http://www.telerik.com/community/forums/silverlight/gridview/radgrid-manifest-error-on-blend.aspx is no more it seems.

    I'm using RadControls for WPF Q2 2009 with Telerik.Windows.Controls.GridView.dll version 2009.2.0701.35

    The error I get when trying to edit a copy of the Template is something like:
    The Type reference can't find any public type called 'RadGridView'

    (sorry I can't give the exact message, some one did something nasty and installed a Swedish OS :p thus sometimes gives the messages in Swedish)
  5. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 17 Nov 2009 Link to this post

    Hello Roger Andersson,

    It seems that Blend cannot load the whole style/template of RadGridView correctly due to a problem in our control. We could possibly send you the template/style of RadGridView for a specific theme that you can work with.

    Greetings,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  6. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 17 Nov 2009 Link to this post

    That would be great :)
    We got our own theme and that has some green in it so all headers, rows and hovering that now is yellowish needs to be changed.


    UPDATE: We just upgraded to 2009 Q3 so if you make this do it for this version.
  7. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 19 Nov 2009 Link to this post

    Hi Roger Andersson,

    I just remembered that we actually ship all of our themes with our SL releases. You can find our Themes.sln solution in the installation folder of RadControls for Silverlight under Themes. The solution contain all styles and templates of our controls for all of our themes.

    If you need any help with the styling do not hesitate to ask.


    All the best,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  8. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 24 Nov 2009 Link to this post

    We don't use VS 2k10 yet, so do you got this for VS 2k8 too?
    cos I can't open it and try to understand all these by using notepad ain't that easy :P
  9. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 27 Nov 2009 Link to this post

    Hi,

    We don't have any Visual Studio 2010 projects - all projects are Visual Studio 2008 compatible.

    Best wishes,
    Vlad
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  10. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 27 Nov 2009 Link to this post

    That's weird cos this and lots more solutions/projectsd from here are inpossible for me to open up.

    I get this(-type of) error for all the proj/sln I can't open from here:

    The project file 'C:\Themes\Summer\Summer.csproj' cannot be opened.
    The project type is not supported by this installation.

    Opening these by using the solution file just gives me the same error for all project files included in the sln file.
    As far as I know everything is installed as it should be.

    UPDATE: Now also tried this on all VS2k8 installations we get and get the same result
  11. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 03 Dec 2009 Link to this post

    Hi Roger Andersson,

    It seems that you might not have Silverlight 3 or  Silverlight Tools for SL3 installed on your system. Although all of our projects are Visual Studio 2008 compatible they require Silverlight 3. Could you please confirm that Silverlight Tools are installed on your system.


    All the best,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  12. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 08 Dec 2009 Link to this post

    Just visited MS' SilverLight webpage and that one says:
    The version of Silverlight installed is: Silverlight 3 (3.0.40818.0)
  13. Milan
    Admin
    Milan avatar
    1989 posts

    Posted 10 Dec 2009 Link to this post

    Hi Roger Andersson,

     What about Silverlight Tools for Visual Studio 2008? Here is link to the download location - http://www.microsoft.com/downloads/details.aspx?familyid=9442b0f2-7465-417a-88f3-5e7b5409e9dd&displaylang=en


    Best wishes,
    Milan
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
  14. Roger Andersson
    Roger Andersson avatar
    15 posts
    Member since:
    Jul 2009

    Posted 15 Dec 2009 Link to this post

    I was missing that and now I won't get an error when trying to open it up, thx :D
    The bad part is that my installation is about to go bust :P cos it keeps crashing al the time :(

    thx for the help :)
Back to Top