This is a migrated thread and some comments may be shown as answers.
empty please enable and compile project first
16 Answers 202 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Willem
Top achievements
Rank 1
Willem asked on 13 Apr 2009, 09:08 PM
Hello,

I have installed OpenAcces in Visual studio 2008, and if I try to use it, I'l get this message <empty please enable and compile project first>. What is the meening of this?

I have compiled it and compiled it two times more still get this message. What is the meening of enable it?

What should I do to get it working?

Thanks

16 Answers, 1 is accepted

Sort by
0
Zoran
Telerik team
answered on 14 Apr 2009, 07:44 AM
Hi Willem,

Since you are new to OpenAccess I'd strongly recommend you have an overview of the "Getting Started" header of our documentation.  The message you reported is part of the wizard for OpenAccessDataSource in an ASP .Net page. Here is additional link from our KB on how to use the datasource for binding objects in web scenario.

All the best,
Zoran
the Telerik team

Check out Telerik Trainer , the state of the art learning tool for Telerik products.
0
WebDevIce9
Top achievements
Rank 1
answered on 07 Aug 2009, 03:10 AM
Zoran, what kind of answer is that? How about you actually post something useful. I think when people post on news groups they are asking for TECHNICAL help to save them time. Telling them to go read something is not that helpful. Then people like me come behind with the same issue and we see this...
0
WebDevIce9
Top achievements
Rank 1
answered on 07 Aug 2009, 03:34 AM
Here is the fix:
1. Right click on your data project (not your consuming project)
2. Choose enable project.
3. Make sure DAL and Peristent is checked.
4. Right click on your solution and choose BUILD.
5. Go back to your datasource and try to reconfigure it again by clicking on the little arrow.
The message should go away and your data project should show up now.
0
Peter Brunner
Telerik team
answered on 07 Aug 2009, 09:13 AM
Hello WebDevIce9,

Thanks for the hints provided.

Concerning your comment to Zoran, I want to mention that his answer is appropriate and helpful. As mentioned in my other post to you a minute ago, it is the best way to take some time and to learn more about the basics. So linking to documentation and examples is a good answer.

If the answer is not helpful for the customer who has posted the question, he would contact us again and receive help until he is satisfied.

Greetings,
Peter Brunner
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
WebDevIce9
Top achievements
Rank 1
answered on 07 Aug 2009, 04:06 PM
No, actually it's not helpful. I invite you to copy and paste specific technical steps or details that explain how to fix this issue. Just like I did! You will not find it. Support is more than just assuming everybody developing has not read the documents and tried the samples. It's offering real world technical solutions.
0
Peter Brunner
Telerik team
answered on 10 Aug 2009, 07:39 AM
Hi WebDevIce9,

Again, we are sorry for your unusual disappointment.

Our customers tell us on a daily basis how well satisfied they are with the support provided. We spend extensive time on all our cases and again, we help the customer until he got a solution.

Our first priority is to support our customers, so please stop to spread very subjective stuff here which is just far from reality.

Please describe concrete issues in a proper way so that we can help you.

Kind regards,
Peter Brunner
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Schmidty
Top achievements
Rank 2
answered on 29 Sep 2009, 01:29 AM
I have tried enabling the web site, and I too am getting the "empty please enable and compile project first". I have an object scope provider in a class library, and for whatever reason it is not finding it properly. Nothing seems to work.

I've exhausted all options that I know of & am looking for suggestions on to get this working.

Thanks.
0
PetarP
Telerik team
answered on 30 Sep 2009, 05:19 PM
Hello Schmidty,

I assume that the class library is holding your persistent classes as well. In such case you will need to rebuild your class library project in order to build the assembly that will be used by the OpenAccessDataSource control to resolve the Object Scope Provider. Please be sure that you have recompiled your class assembly before attempting to use our data source control.
Please feel free to contact us if any further difficulties arise.

All the best,
Petar
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Alfred Ortega
Top achievements
Rank 2
answered on 02 Oct 2009, 04:16 PM

When using OA with websites the class library must also provide the ScopeProvider. 

 

1) class library is OA Enabled + generates classes + generate DAL.

 

2) website is OA Enabled.

 

3) compile all and then you should be able to use the OpenAccessDataSource.

 

hth,

Al

0
Schmidty
Top achievements
Rank 2
answered on 02 Oct 2009, 07:16 PM
The odd thing is I got it to work on another project, but it had the DAL/Models in one class library.

I currently have:

- 1 class library that holds the DAL/Persistence code (OA Enabled)
- 1 class library that holds my domain model classes (OA Enabled)
- the web site.

I've added references to the two libraries to my site. Both have been rebuilt numerous times. Even when I enabled OA for the website it still does not find my ObjectScopeProvider in my DAL library. Enabling and rebuilding the web site still doesn't help the OpenAccessDataSource find the scope provider.
0
Damyan Bogoev
Telerik team
answered on 06 Oct 2009, 04:05 PM
Hello Schmidty,

Make sure that you did the following:

-    Open web.config and locate the references node inside the openAccess configuration section.
-    Make sure there are references to the class libraries in the references node. It should have the following form:

<references> 
    <reference assemblyname="ClassLibrary1" configrequired="True"/> 
    <reference assemblyname="ClassLibrary2" configrequired="True"/> 
</references> 

-    Recompile
-    Locate and open the aspx page where you use an OpenAccessDataSource;
-    Switch to the design view;
-    Click on OpenAccessDataSource and choose Configure Data Source;
-    Inside the OpenAccess Data Source Wizard you can choose the data context your application use to access the database(DAL/Persistence or Domain model class library) and which persistent type you want to retrieve;

If taking these actions does not solve your problem, please let us know so we can dig further in order to find the right solution.

Greetings,
Damyan Bogoev
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Erik
Top achievements
Rank 2
answered on 06 Dec 2011, 10:23 PM
Hi all,

Today I found out that a solution (1 data project containing a rlinq model and a webapplication proj) that resides on a network mapping, NEVER finds any rlinq models and always displays "<empty, please enable and compile project first>"

When I copied it to a local disk, the problem disappeared...

Erik
0
Erik
Top achievements
Rank 2
answered on 06 Dec 2011, 10:23 PM
I got an oops from the server...
0
Damyan Bogoev
Telerik team
answered on 08 Dec 2011, 05:29 PM
Hello Erik,

I reproduced the wrong behavior. The OpenAccessDataSource does not resolve the corresponding persistent types correctly. We will fix the cause for this issue and include the fix in the next internal build of the product.
Actually you could use the new OpenAccessLinqDataSource to achieve that goal. Helpful information regarding the data source can be found here
I am sorry for the inconvenience caused. You could find your Telerik points updated.


Greetings,
Damyan Bogoev
the Telerik team

Q3’11 of Telerik OpenAccess ORM is available for download. Register for the What's New in Data Tools webinar to see what's new and get a chance to WIN A FREE LICENSE!

0
Erik
Top achievements
Rank 2
answered on 08 Dec 2011, 05:34 PM
Thanks Damyan,

Indeed the new OpenAccessLinqDataSource (Since Q3 2011) does not have this problem. Found out yesterday and tested it, this control works fine.

I posted here because this was the first thread I found when googling, so others with the same problem can find it to.

Erik
0
Fredrik
Top achievements
Rank 2
answered on 15 Mar 2013, 02:36 PM
WebDevIce9 has a valid point here and i am just stating that because this i a common issue with support.
I have heard alot of praise on your products and support and i have only good experience so far, but that doesnt make him wrong.
Good support can sometimes be done by just refering to good documentation. But that should only be done with a link to a step by step solution.

But, to finish of this... You have great products and support as far as i have seen so far.
So keep it up =)
Tags
Getting Started
Asked by
Willem
Top achievements
Rank 1
Answers by
Zoran
Telerik team
WebDevIce9
Top achievements
Rank 1
Peter Brunner
Telerik team
Schmidty
Top achievements
Rank 2
PetarP
Telerik team
Alfred Ortega
Top achievements
Rank 2
Damyan Bogoev
Telerik team
Erik
Top achievements
Rank 2
Fredrik
Top achievements
Rank 2
Share this question
or