This is a migrated thread and some comments may be shown as answers.

Dropping a RadGridView on Blend 4 beta artboard crash

9 Answers 51 Views
GridView
This is a migrated thread and some comments may be shown as answers.
Marc Roussel
Top achievements
Rank 2
Marc Roussel asked on 08 Apr 2010, 12:28 AM
Crash with HRESULT E_FAIL with no InnerException.
See this video available between 6:00am and 8:00pm EST

Weird behaviour

The first time I load Blend 4 beta and add a RadGridView everything seems find but as soon as I hit F5, Blend 4 crash
but the application runs once I return to Blend 4 I see the crash

9 Answers, 1 is accepted

Sort by
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:31 AM
What is also interesting here is that if I have VS2010 RC loaded and hit F5 in VS2010, I look at Blend 4 during the run and boom it crash in Blend 4 !?
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:45 AM
Finally, after a phew tests, Just loading the project in Blend 4, with the Grid visible and doing a REBUILD will give the same result
I started a totaly new project from scratch and I have the same result

Also, if I delete the RadGridView from the artboard by the xaml code since I'm unable to do anything from the artboard, everything is back to normal

Oh and if I stay in the same session, even tought everything seems normal if I just drop the grid on the artboard again it crash
I have to close Blend 4 and reopen it to see the grid but anything I will do with it will make blend 4 crash
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:21 PM
Have the same issue with the latest internal build : 2010.1.402.1040
This is very annoying.  Any ideas ?
0
Vlad
Telerik team
answered on 08 Apr 2010, 12:24 PM
Hi Marc,

I've tried to access the movie however it seems that this is not available currently.

Sincerely yours,
Vlad
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:25 PM
It is, I'm already listening it.  It's available to me.  What are you getting ? I mean it's on the web and really available right now
0
Vlad
Telerik team
answered on 08 Apr 2010, 12:29 PM
Hello,

The browser just cannot connect to this url.

All the best,
Vlad
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:32 PM
Previous version
http://cid-7056cffe05236b7d.skydrive.live.com/self.aspx/.Public/weird.zip?ccr=1351


Latest internal build
http://cid-7056cffe05236b7d.skydrive.live.com/self.aspx/.Public/Latest%20Internal%20Build.zip

I even added all the Telerik reference in case I would have missed one
in my latest test with the latest internal build
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 12:37 PM
You're right there's a problem accessing it.  Sorry.  I will make it available via download instead.  It seems my ClientBin/Videos directory from my site isn't available but I don't know why
0
Marc Roussel
Top achievements
Rank 2
answered on 08 Apr 2010, 01:58 PM
For the crash I seem to have solved it.  What I did ?
Well, I had the Silverlight 4 dlls in a directory so I just downloaded the installer, installed it and then it crearted
a directory in Program files(x86)\Telerik\RadControl......RC and I referenced the dll from there and now no more crash

I noticed also that I don't have the Telerik reference in the .NET tab when adding a reference from VS2010RC
Tags
GridView
Asked by
Marc Roussel
Top achievements
Rank 2
Answers by
Marc Roussel
Top achievements
Rank 2
Vlad
Telerik team
Share this question
or