Documentation Error in Q1/2009

7 posts, 1 answers
  1. Jani
    Jani avatar
    61 posts
    Member since:
    Jan 2008

    Posted 13 Mar 2009 Link to this post

    I have a Microsoft Document Expolorer Exception when I click any topic within the Contents tree.
    Reinstalling the help using RegisterHelp.bat does not fix this issue.

    Jani
  2. Scott
    Scott avatar
    1 posts
    Member since:
    Aug 2007

    Posted 13 Mar 2009 Link to this post

    Same problem here. I downloaded the CHM file and it does not work either.
  3. Hristo Deshev
    Admin
    Hristo Deshev avatar
    559 posts

    Posted 16 Mar 2009 Link to this post

    Hi guys,

    For a short while we had on the site an installer with a corrupted help installation, and maybe that is the time you downloaded your installers and CHM distributions. I just tested both the installer and the CHM distro, and both of them seem to be working just fine.

    Please try downloading the bits again and try them out. Sorry for the trouble.

    Greetings,
    Hristo Deshev
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  4. Jani
    Jani avatar
    61 posts
    Member since:
    Jan 2008

    Posted 17 Mar 2009 Link to this post

    Hi Hristo,

    I have still the same Exception using the newest Setup (RadControls_for_Silverlight_2009_1_0312_DEV.msi, 84'822'528 bytes).
    The documentation of Q3/2008 works without trouble.

    Cheers,
    Jani
  5. Answer
    Hristo Deshev
    Admin
    Hristo Deshev avatar
    559 posts

    Posted 18 Mar 2009 Link to this post

    Hi Jani,

    I just discovered and fixed a problem with the RadControls for Silverlight help registration, and I was wondering if your problem might be caused by the same thing. I guess we can try fixing that problem on your end and see if it eliminates the crash.

    The help registration process is driven by an INI file located at C:\Program Files\telerik\RadControls for Silverlight Q1 2009\Documentation -- it is named telerik.windows.controls.ini. I am attaching a fixed version to this message -- please overwrite your original file with that. After you have the fixed version in place, run the UnRegisterHelp.bat file, and, when it finishes, run RegisterHelp.bat. Now you can try opening the documentation from the Start menu link.

    Tell me if that fixes the problem. If it does not, please send or paste your H2Reg_Log.txt file (again found in the Documentation folder). I hope that log file will contain an error message that might give me a clue on what is really going on.

    Kind regards,
    Hristo Deshev
    the Telerik team


    Instantly find answers to your questions on the new Telerik Support Portal.
    Check out the tips for optimizing your support resource searches.
  6. Jani
    Jani avatar
    61 posts
    Member since:
    Jan 2008

    Posted 18 Mar 2009 Link to this post

    Hi Hristo,

    Thanks for the fix - it works now.

    Cheers,
    Jani
  7. Frederic Aube
    Frederic Aube avatar
    2 posts
    Member since:
    May 2004

    Posted 28 Mar 2009 Link to this post

    I can confirm that the provided fix works!
Back to Top