Do demos now require SL4?

20 posts, 0 answers
  1. Dan Dyer
    Dan Dyer avatar
    4 posts
    Member since:
    Mar 2010

    Posted 22 Apr 2010 Link to this post

    I am developing for Silverlight 3 right now and all of a sudden today, the demos on the telerik site are asking me to upgrade to SL4. If the code and behavior are the same, I could probably live with the change, but am wondering if the SL3 demos will still be available on the telerik site so I can run them with SL3 and not have to upgrade my system to SL4.
  2. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 23 Apr 2010 Link to this post

    Hi,

    Indeed we plan to have separate Silverlight 3 demos.

    Greetings,
    Vlad
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Dan Dyer
    Dan Dyer avatar
    4 posts
    Member since:
    Mar 2010

    Posted 23 Apr 2010 Link to this post

    Please post the URL when the SL3 demos are again available.
  4. Hristo
    Admin
    Hristo avatar
    408 posts

    Posted 27 Apr 2010 Link to this post

    Hello Rich Tett,

    The online demos for RadControls for Silverlight 3 are available here: http://demos.telerik.com/silverlight/silverlight3.

    Regards,
    Hristo
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  5. lori guymon
    lori guymon avatar
    23 posts
    Member since:
    May 2004

    Posted 07 May 2010 Link to this post

    Thank you, Hristo, for posting this link to the SL3.  I am on SL4 and just learning about the controls but the changes in the navigation of topics and content on the SL4 demo is really frustrating to use and I will use the SL3 demo instead.  

    The SL4 demo is beautiful but I for one get completely lost as I am constantly having to "startover" and lose the content I was viewing just so I can see what other topics are available for the same control.  I often times click on the SAME topic I just viewed because I wasn't sure what I had been previously viewing.  The navigation on the left in the previous version (SL3) allowed one to review the topics for all controls at once and quickly switch from one topic to the next - without losing your place in the "topics tree".  Being able to see the whole topic tree and scroll through it was so helpful and very much like industry standard help applications.  In addition, the content area in the SL3 version is very large compared to the very small content area in the new demo (though I wish I could see more than 5 lines of text at a time in both!).

    I really appreciate Telerik's efforts in doing the demos as they are SOOO helpful to us.  I may be the only customer disgruntled about the new navigation but I just can't use it to help me learn the toolset any longer - or at least without getting completely frustrated.  The SL3 version is amazing so I hope it sticks around for a bit until I learn the controls.



  6. Ivan
    Admin
    Ivan avatar
    519 posts

    Posted 07 May 2010 Link to this post

    Hi lori,

    Thank you for sharing your notes. We will consider them in our feature development.

    About the consecutive navigation through examples please use the navigation control just above the example page:
     
     
     
    We hope this wil help you to preview our examples easily.

    Kind regards,
    Ivan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  7. joe castle
    joe castle avatar
    39 posts
    Member since:
    Jan 2005

    Posted 10 May 2010 Link to this post

    I have to say that I agree with lori. I think the new demo is beautiful, the new navigation is pleasant to look at but I click myself to death with it :). We can use the arrow on the side but you don't know what you will see...
  8. Hristo
    Admin
    Hristo avatar
    408 posts

    Posted 12 May 2010 Link to this post

    Hello joe castle,

    Thank you for your nice words and feedback. We'll going to consider the possibilities to add some visual clues which one is the next example before someone clicks on the navigation arrows.

    Sincerely yours,
    Hristo
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  9. Daniel Billingsley
    Daniel Billingsley avatar
    95 posts
    Member since:
    Apr 2010

    Posted 24 May 2010 Link to this post

    Add me to the list of people who thinks the new navigation is a step backward.

    However, one of the problems with some of the old demos was there wasn't really enough screen space to see a good example because so much was taken up by the menu on the left.  If you can find the best of both worlds, perhaps with a flyout, it would be better.
  10. Hristo
    Admin
    Hristo avatar
    408 posts

    Posted 25 May 2010 Link to this post

    Hello Daniel Billingsley,

    Thank you for your feedback. We'll include your suggestion in our next discussions for demo improvements.

    Best wishes,
    Hristo
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  11. ryan
    ryan avatar
    21 posts
    Member since:
    Aug 2010

    Posted 28 Sep 2010 Link to this post

    For some reason I can't run the silverlight demos anymore even though I have the silverlight 4 plugin.  Did something change with them in the last few days?  I get the error "Could not load file or assembly 'Telerik.Windows.Controls.Input Version=2010.2.927.1040..."  Anyone else having this issue?
  12. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 29 Sep 2010 Link to this post

    Hi ryan,

    Please clear your browser cache and recheck problematic demos. 

    Regards,
    Vlad
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  13. Yuk
    Yuk avatar
    9 posts
    Member since:
    Aug 2010

    Posted 29 Sep 2010 Link to this post

    I got the following error when loading the demo Silverlight 4. I also try to clear the cache.. It always stuck at 30%

    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; GTB6.6; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; .NET CLR 1.1.4322; .NET4.0C; .NET4.0E)
    Timestamp: Wed, 29 Sep 2010 09:41:59 UTC

    Message: Unhandled Error in Silverlight 2 Application [Arg_NullReferenceException]
    Arguments:
    Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=4.0.50826.0&File=mscorlib.dll&Key=Arg_NullReferenceException   at Telerik.Windows.QuickStart.SilverlightDeploymentManager.LoadAssemblyInDomain(Stream resultStram)
       at Telerik.Windows.QuickStart.SilverlightDeploymentManager.<>c__DisplayClass17.<LoadAssembly>b__16()
       at Telerik.Windows.QuickStart.LoaderService.ThreadSafeCallBack(Action callback)
       at Telerik.Windows.QuickStart.SilverlightDeploymentManager.LoadAssembly(Stream xapStream, String assemblyName)
       at Telerik.Windows.QuickStart.SilverlightDeploymentManager.<>c__DisplayClassf.<DownLoadRefAssemblies>b__c(OpenReadCompletedEventArgs e)
       at Telerik.Windows.QuickStart.SilverlightDeploymentManager.<>c__DisplayClass12.<StartDownload>b__11(Object sender, OpenReadCompletedEventArgs e)
       at System.Net.WebClient.OnOpenReadCompleted(OpenReadCompletedEventArgs e)
       at System.Net.WebClient.OpenReadOperationCompleted(Object arg)
    Line: 1
    Char: 1
    Code: 0
    URI: http://demos.telerik.com/silverlight/

     

  14. Kaloyan
    Admin
    Kaloyan avatar
    920 posts

    Posted 01 Oct 2010 Link to this post

    Hello Yuk,

    Have you tried to load the examples with another browser. We are currently investigating what might be causing this problem. Please accept our apologies once again.

    Kind regards,
    Kaloyan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  15. Yuk
    Yuk avatar
    9 posts
    Member since:
    Aug 2010

    Posted 01 Oct 2010 Link to this post

    Have you fixed it? It's working fine now.
  16. Kaloyan
    Admin
    Kaloyan avatar
    920 posts

    Posted 01 Oct 2010 Link to this post

    Hi Yuk,

    We have re upload the site again actually. The assembly caching is always making troubles.

    All the best,
    Kaloyan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  17. Jalal Khalil
    Jalal Khalil avatar
    8 posts
    Member since:
    Dec 2009

    Posted 09 Oct 2010 Link to this post

    Sorry to post my thread here, but i do that since no reply since two weeks : 



    Posted on Sep 25, 2010 (permalink)

    Hello,

    I am trying to use RadCompression on my silverlight project as follows : 

    <httpModules>
       <add name="RadCompression" type="Telerik.Web.UI.RadCompression" />
    <.....

    <system.webServer>
     <add name="RadCompression"  type="Telerik.Web.UI.RadCompression" />
    <.....

    When i run my project, it works fine with firefox ( compression works well). But it doesn't work using IE or Chrome!!

    Any ideas please

    Regards,
  18. Vlad
    Admin
    Vlad avatar
    11100 posts

    Posted 11 Oct 2010 Link to this post

    Hi,

     Can you post more info about Telerik.Web.UI version and your browsers versions?

    Greetings,
    Vlad
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  19. Jalal Khalil
    Jalal Khalil avatar
    8 posts
    Member since:
    Dec 2009

    Posted 11 Oct 2010 Link to this post

    Telerik.Web.UI
    Telerik RadControls for ASP.NET Ajax
    Runtime version : v2.0.50727
    Version : 2010.1.415.35
    -------------------------------------------
    Internet Explorer8 :
    Version : 8.0.7600.16385
    ------------------------------------------
    Chrome : 6.0.472.63
  20. Martin
    Admin
    Martin avatar
    823 posts

    Posted 15 Oct 2010 Link to this post

    Hello Jalal Khalil,

    I have already answered to the other forum thread you have posted in. To avoid duplicate posts I would suggest that we continue our communication there.

    Regards,
    Martin
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top