Could not load 'Telerik.Windows.controls.FixedDocumentViewers'

3 posts, 0 answers
  1. Alaa
    Alaa avatar
    28 posts
    Member since:
    Jun 2014

    Posted 01 Jun 2014 Link to this post


    I'm working with WPF. I encapsulated RadPDFViewer inside ControlTemplate (I did that before for RadGauge and it works good), after I added all the required assemblies.
    In the designer(user control) I can see the component as a gray rectangle but when I run the application it gives me error as u see in the attached file and it doesn't show me the component.
    When I use RadPDFViewer not inside the ControlTemplate, in regular window it works fine.
    Why only 'Telerik.Windows.controls.FixedDocumentViewers' can't be loaded (BTW all my assemblies) are the same version.

    Thank you
  2. Kammen
    Kammen avatar
    313 posts

    Posted 02 Jun 2014 Link to this post

    We have tested your scenario and everything seems to work as expected.

    Please, verify that you are referencing all required references. I am attaching you a sample project that represents this use case and is working well at our side.

    I hope that this will help you solve this problem.

    Check out Telerik Analytics, the service which allows developers to discover app usage patterns, analyze user data, log exceptions, solve problems and profile application performance at run time. Watch the videos and start improving your app based on facts, not hunches.
  3. Alaa
    Alaa avatar
    28 posts
    Member since:
    Jun 2014

    Posted 02 Jun 2014 in reply to Kammen Link to this post

    I solved it. It's huge solution so I have to add this assembly to the startup project.
    Thanks a lot
Back to Top