cordova undefined

Thread is closed for posting
3 posts, 0 answers
  1. KC
    KC avatar
    14 posts
    Member since:
    Feb 2013

    Posted 19 Aug 2014 Link to this post


        I have recently taken over mobile development for my company and I am not very failure with the architecture of what an .app should look like. But, I have been messing around with it and I am getting a grasp on it. Yesterday, after I successfully compiled and tested the test app I shut down. This morning, I turned it on and now the app fails due to an error,
    "Uncaught TypeError: Cannot call method 'hide' of undefined."
    This was all working just fine yesterday and now it wont. Also, in the actual mobile application that I will be working, it throws a similar error but it is with the 'device' not the 'navigator' variables. This is very perplexing because everything worked fine and suddenly it is broken. It also seems that about every other compile, it throws a "cordova is not defined."
    Sometimes it does that one, sometimes it does not.

    Any help would be appreciated. I am running it in the VS extension, cordova version 3.5

    Very respectfully,


    **Note** I can run it on a device without any errors, seems to be local to the simulator.
  2. KC
    KC avatar
    14 posts
    Member since:
    Feb 2013

    Posted 20 Aug 2014 Link to this post


    So, I had to copy all the project files to a new solution... And it works now... Not sure why, but I guess the project did not like where it was living, so I moved it. If you can find a cause of this let me know. 
  3. Iva Koevska
    Iva Koevska avatar
    286 posts

    Posted 22 Aug 2014 Link to this post

    Hi Keith,

    Thank you for contacting Telerik support. We are glad that you have been able to find a workaround.

    Another viable workaround, should you find the simulator becoming corrupted again is to clear the AppBuilder cache. After you have closed the simulator and the extension, you can go to %localappdata%\Telerik\BlackDragon and remove the Cache folder. This should cause the simulator, on next start, to reset and repair itself.

    Usually, the reported behavior occurs when you run the VS extension and the Windows client simultaneously, or when a process locks one or more files in your project. 

    We would appreciate any additional details about the original project, setup and situation with which you observed the issue, as this might help us identify the culprit and reduce the occurrence of such issues in the future.

    Iva Koevska

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top