Cannot record or playback after patching Windows and Visual Studio

2 posts, 0 answers
  1. Hugues Ferland
    Hugues Ferland avatar
    14 posts
    Member since:
    Oct 2009

    Posted 15 Oct 2010 Link to this post

    Hi,

    I've not been able to record nor playback correctly since I installed Windows Update patches.  We use Windows XP Professional Edition x64 Version 2003 Service Pack 2.  We use both Visual Studio 2008 and 2010.   My WebUI Test Studio version is 1010.1. The recording and playback problem appear in both Visual Studio versions.

    When trying to record, the recording toolbar does not appear on IE (7) and I get the "Failed to launch the browser" error.  When I try to playback old tests, it fails timing out on the first step (NavigateTo) : System.TimeoutException: Wait for condition has timed out. Curiously, I can see the page loaded in the browser.

    I look on the this forum for solutions related to the "Failed to launch the browser".  I followed the solution you suggested to other users.

    1) I disabled all IE's add-ons except WebAii Test Execution Extension and WebUI TestStudio Recorder. 
    2) I tried to set the browser settings as described here.  Some settings are managed by our system administrator (for instance, I don't have the checkbox "Enable Protected Mode".   But since it used to work I presume the problem is probably related to my upgrades but I double checked the settings I have control over and it seems ok.
    3) I tried running Visual Studio as administrator.  I did it by unchecking the checkbox "run this program with restricted access".  Not sure if this is enough.
    4) I reinstalled WebTest Studio.

    I'd been interested to know if you have some more ideas to diagnostic where the problem lies.

    Thank you very much
  2. Cody
    Admin
    Cody avatar
    3354 posts

    Posted 22 Oct 2010 Link to this post

    Hello Pascal Guy,

    I apologize for the delay responding to you. Are you still having a problem?

    This is the first we've heard about problems relating to installing Microsoft patches. For Windows XP, there isn't such a thing as "Run as administrator". If you are logged into an account that is a member of the local Administrator group, then it is being run at administrator level. Just FYI, this changed in Vista and Windows 7. Those versions of windows have a new "Run as administrator" option.

    Have you tried doing a repair install of WebUI? You do this by running the install package again and you will get the repair prompt. If that doesn't work, the next thing I would try is uninstalling and reinstalling WebUI.

    Let me know if any of that helps.

    Kind regards,
    Cody
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top