Cannot find hostname in file :/// from static

Thread is closed for posting
2 posts, 0 answers
  1. Marat
    Marat avatar
    2 posts
    Member since:
    Mar 2015

    Posted 16 Jun 2016 Link to this post

    Hi there, 

    I'm developing an app with the App Builder and trying authorize through Google using oauth2. I had obtained the Client ID and Secret client by choosing 'Web application' and have linked them with Google Mail (Integrated APIs) on When I click 'Try auth' on, popup window shows 'Successfully connected with google', but when I run my app in the App Builder's simulator, 'This plugin is not available in the simulator' message pops up. When I run it on the physical device , it displays the following error message: 'code: InvalidHeader; message: Cannot find hostname in file :/// from static'. So, how can I fix this auth issue?

  2. Tsvetina
    Tsvetina avatar
    2481 posts

    Posted 20 Jun 2016 Link to this post

    Hi Marat,

    I am copying the reply from the support thread you opened in case anyone encounters the same problem. If you have additional questions or comments, please post them in the support thread.

    Using custom plugins in the device simulator isn't a supported option and that is why you get the error there. You can see more information about the simulator limitations here. As for mobile devices, without seeing your project, it is hard to determine the cause of the issue. Confirm that you are using the plugin from the verified plugins marketplace:

    There are detailed instructions about the plugin usage in this page and a link to a sample app.


    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top