Can't install the VS4MAC extension

9 posts, 0 answers
  1. Bernd
    Bernd avatar
    91 posts
    Member since:
    Feb 2013

    Posted 15 Sep 2017 Link to this post

    Dear Telerik Team.
    First of all: Thank you for including the Xamarin stuff in my subscription.

    Eager to try it I started a prototype project.
    Then I ran into an error. But your ticket system didn't want me to send it. :) Here ist the ticket message:

    I tried to install the VS4MAC extension, but it failed. As described
    here: https://developer.telerik.com/featured/ui-xamarin-deep-dive-starting-strong/.
    I installed the nuget and downloaded the lastest zip file. Version
    Telerik_UI_for_Xamarin_2017_3_913_3_Dev.

    Trying to install the mpack gives my the enclosed error message. It seems the mpack isn't updated yet.

    Besides that your ticket system tells me: "Message required". But I wrote a
    message. Maybe it didn't like the pasting in of my screenshot. I'll try
    attaching it as file.

    No. Didn't work. I restart the tiket submission. Maybe it works now.

    No. I'll select the option OS parameter. Maybe now.

    Kind regards
    Bernd

  2. Pavel R. Pavlov
    Admin
    Pavel R. Pavlov avatar
    1246 posts

    Posted 19 Sep 2017 Link to this post

    Hi Bernd, 

    I would like to turn your attention to the fact the reported message is a warning, not an error. You should be able to use the extensions with no concerns.

    Please give them a try and let us know how it goes.

    Regards,
    Pavel R. Pavlov
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Bernd
    Bernd avatar
    91 posts
    Member since:
    Feb 2013

    Posted 21 Sep 2017 in reply to Pavel R. Pavlov Link to this post

    Dear Pavel.

    Thank you for your response. I gave it a try, but the extension is grayed out.

    Kind regards

    Bernd

  4. Stefan Nenchev
    Admin
    Stefan Nenchev avatar
    657 posts

    Posted 25 Sep 2017 Link to this post

    Hello, Bernd,

    Would it be possible to provide a short recording of the exact behavior that you are observing so we can further advise you? 

    Regards,
    Stefan Nenchev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Bernd
    Bernd avatar
    91 posts
    Member since:
    Feb 2013

    Posted 11 Oct 2017 in reply to Stefan Nenchev Link to this post

    Dear Stfan.

    Sorry for the delay. I am soon on a vacation and guess what: the whole world "needs" a lot of work done before I leave. I'll try to deliver more details after my vacation.

    Kind regards

    Bernd

  6. Stefan Nenchev
    Admin
    Stefan Nenchev avatar
    657 posts

    Posted 16 Oct 2017 Link to this post

    Hi, Bernd,

    Thanks for the update. Take the needed time at your end and inform us once you are ready. 

    Regards,
    Stefan Nenchev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  7. Larry
    Larry avatar
    26 posts
    Member since:
    Mar 2008

    Posted 22 Nov 2017 in reply to Stefan Nenchev Link to this post

    I am seeing the exact same error.  And it is an error, because the template is never applied. So there is not a template to select for Telerim UI for Xamarin project type.
  8. Lance | Technical Support Engineer, Principal
    Admin
    Lance | Technical Support Engineer, Principal avatar
    861 posts

    Posted 22 Nov 2017 Link to this post

    Hello Larry and Bernd,

    The reason for that error message is because the mpack is built for Xamarin Studio (which uses Mono 6.x), not Visual Studio for Mac (which uses Mono 7.x). Although you can still use many extensions across both, you will see that message when installing it (not just the UI for Xamarin one)

    If you're not seeing the Telerik project templates under the .NET > Miscellaneous tab, then take the following steps:

    1 - Go back to the "Extensions..." dialog again
    2 - Expand IDE
    3 - Find and select the Telerik item
    4 - Click the Disable button and then click it again to re-enable the extension
    5 - At this point, you can go back to File > New project and find the Telerik project template under the NET > Miscellaneous tab.

    We are working towards creating one for Visual Studio for Mac. However, for now, that is the only available option when using a Mac.

    Regards,
    Lance | Tech Support Engineer, Sr.
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  9. Larry
    Larry avatar
    26 posts
    Member since:
    Mar 2008

    Posted 28 Nov 2017 in reply to Lance | Technical Support Engineer, Principal Link to this post

    That worked fine.
Back to Top