Buttons will not re-enable

4 posts, 1 answers
  1. Doug
    Doug avatar
    2 posts
    Member since:
    Sep 2010

    Posted 06 Jul 2012 Link to this post

    I am using the Q2 2012 Silverlight controls and have a collection of RadRibbonToggleButtons in a RadRibbonView that are bound to a DelegateCommand.  These buttons can become enabled or disabled over the course of the program running through the CanExecute functionality of the DelegateCommand.  The problem I'm running into is that while buttons on RadRibbonTabs other than the current one will be disabled properly when you navigate to that tab, but if you have previously viewed the tab the buttons will not become re-enabled after being disabled.  Buttons on the current tab will change as expected.

    I tried using the RadRibbonView.SelectionChanged event and a binding on RadRibbonView.SelectedItem to manually invalidate CanExecute, but it does not work the first time you go to the tab, only on the next time you go to the tab.  For example you are viewing tab 1 when all the buttons ought to become enabled, then you go to tab 2 and the buttons are still disabled, but if you go to tab 3 then back to tab 2 the buttons are enabled.

    Is there some other way to get the buttons to enable at the right time or will I have to wait for a bug fix?
  2. Bruno
    Bruno avatar
    54 posts
    Member since:
    Jul 2012

    Posted 09 Jul 2012 Link to this post

    Hi Doug

    Thank you for your post. We do have the same behavior in our Application. We tried everything to get it work... but there seems to be no workaround.

    We got back to Q1.2012 and tried all 'internal builds' to see when the changes where made by Telerik. The latest version that works (as it should) is 2012.1.416.1050.

    As long as this bug exists we can not update to Q2.2012...
    Dear Telerik-Team, please resolve this bug as soon as possible.

    Thank you!
  3. Answer
    Zarko avatar
    755 posts

    Posted 11 Jul 2012 Link to this post

    Thank you for the feedback. There really seems to be a problem with the CanExecute inside a RibbonView and I logged it in our PITS under the name "CanExecute doesn't work correctly inside collapsed RadRibbonTabs" and it'll be ready for voting and tracking tomorrow the latest. I hope that this bug will be fixed for our next internal build or the upcoming Service Pack.
    For now I was able to find one workaround - handle the loaded event of your RadRibbonGroup and invalidate the command there.
    I've attached a sample project and if you have further questions please feel free to ask.

    All the best,
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  4. Doug
    Doug avatar
    2 posts
    Member since:
    Sep 2010

    Posted 11 Jul 2012 Link to this post

    Yes that does seem to work.  I had tried the Loaded event on the RadRibbonTab, but that had no effect, so I looked elsewhere for a workaround.  Thank you.
Back to Top