Build UWP for Store causes System.IO.FileNotFoundException in mscorlib.ni.dll Could not load clrcompression

4 posts, 0 answers
  1. Russ
    Russ avatar
    19 posts
    Member since:
    Jan 2017

    Posted 14 Feb 2017 Link to this post

    Why is this happening for my UWP project at runtime in the forms.init call? I started getting a similar error when I did a store build. It could not find System.Private.Reflection.Core.dll instead of mscorlib.ni.dll in release mode. It builds ok, but I get the runtime error when running the release mode. So, I went back to debug mode and stated getting the error on mscorlib.nio.dll. I reverted back to my last good build on TFS and I am still getting these errors. In debug mode, mscorlib.ni.dll and release mode, system.private.reflection.dll. I have cleaned, deleted obj and bin, rebuilt to no avail. This has me stumped. anyone else having this? Another clue, The store build kind of runs, but my images on the home page are missing, they are embedded resources. For the release build I have tried to load the assemblies, but I am having a hard time knowing what the exact mane of the assemblies are. For debug, it used to in as is, with no assemblies loaded before the init.
    Here is what I found on this topic and tried all suggestions in these posts. Not sure how to determine all the assemblies needed for release mode, how does one know what to put in there?
    Here is what I have so far for the release mode problem, but I am shooting in the dark as I am not sure if these are correct nor complete.

     

    var otherAssemblies = new[] {typeof(MR.Gestures.ContentPage).GetTypeInfo().Assembly,

    typeof(MR.Gestures.UWP.Renderers.PageRenderer).GetTypeInfo().Assembly,

    typeof(HomePage).GetTypeInfo().Assembly,

    typeof(ImageCircle.Forms.Plugin.UWP.ImageCircleRenderer).GetTypeInfo().Assembly,

    typeof(Telerik.XamarinForms.Common.UWP.TelerikForms).GetTypeInfo().Assembly,

    typeof(Telerik.XamarinForms.Common.UWP.RadViewContainer).GetTypeInfo().Assembly,

    typeof(SQLite.SQLite3).GetTypeInfo().Assembly,

    typeof(Telerik.XamarinForms.DataControls.RadListView).GetTypeInfo().Assembly

    ,typeof(Telerik.XamarinForms.DataControlsRenderer.UWP.ListViewRenderer).GetTypeInfo().Assembly,

    typeof(Telerik.XamarinForms.DataControls.ListView.ListViewGridLayout).GetTypeInfo().Assembly,};

     

    Xamarin.Forms.Forms.Init(e, otherAssemblies);

     

    https://developer.xamarin.com/guides/xamarin-forms/platform-features/windows/installation/universal/#Target_Invocation_Exception_when_using_Compile_with_.NET_Native_tool_chain
    https://forums.xamarin.com/discussion/comment/246158
    and another one:
    [http://stackoverflow.com/questions/34424184/why-does-my-xamarin-pcl-throw-a-runtime-exception-when-building-release-for-univ]
    Any other ideas? I cannot even run the app in debug mode now.

  2. Russ
    Russ avatar
    19 posts
    Member since:
    Jan 2017

    Posted 14 Feb 2017 Link to this post

    What are the assemblies I would need for Telerik controls?
  3. Rosy Topchiyska
    Admin
    Rosy Topchiyska avatar
    586 posts

    Posted 16 Feb 2017 Link to this post

    Hi Russ,

    Thank you for contacting us.

    We have articles in our documentation with required assemblies for each component. They are located in the [Component section]/Getting Started section. For example, the listview documentation is here:
    We couldn't observe the described issue on our side. Could you first confirm that the issue is caused by Telerik assemblies? If so, could you please prepare a sample project that demonstrates the issue?

    Regards,
    Rosy Topchiyska
    Telerik by Progress
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  4. Russ
    Russ avatar
    19 posts
    Member since:
    Jan 2017

    Posted 17 Feb 2017 in reply to Rosy Topchiyska Link to this post

    not sure yet. I have a temporary work around which is to run my UWP app on another machine. Will let you know next time I attempt a store build.
Back to Top