Build Isn't Creating the Latest Version of the App

4 posts, 0 answers
  1. Jordan
    Jordan avatar
    16 posts
    Member since:
    Mar 2013

    Posted 24 Jul 2013 Link to this post

    I've been trying to refresh my app on my phone and it acts like it is updating the app but it hasn't been able to get any new code updates since July 23rd afternoon. I've tried updating the app manually from my Android phone and also from scanning the QR code in Graphite and Mist. The build log doesn't show any errors and everything looks like it is working BUT no new changes are being built. The simulator correctly shows all the new changes but the app built for my phone doesn't. I've uninstalled several times thinking that maybe deleting everything would fix the problem on my phone but it hasn't.

    Also, why am I getting "Invalid post content" every single time I try to post a thread? 
  2. Steve
    Steve avatar
    10941 posts

    Posted 25 Jul 2013 Link to this post

    Hi Jordan,

    We would need more information:
    • how do you normally develop in Icenium - Graphite with LiveSync (USB cable) or scanning QR code? The project LiveSync should automatically turn on as soon as you connect your device to your machine so if it is being off, most likely means an error has occurred when communicating with the device (see top right corner for disconnected plug). If there is an error, please check the Graphite logs for a stack trace and provide it here for reference. You can also try to disconnect your device, restart it, and then connect it again. If you're scanning the QR code, there is no need for continuous scanning, just use the the three fingers tap gesture to refresh your app.
    • what is your device model and Android OS version?


    Do you enjoy Icenium? Vote for it as your favorite new product here (use short code H048S).
    Looking for tips & tricks directly from the Icenium team? Check out our blog!
    Share feedback and vote for features on our Feedback Portal.
  3. Jordan
    Jordan avatar
    16 posts
    Member since:
    Mar 2013

    Posted 25 Jul 2013 Link to this post

    Hi Steve,

    I almost always use Graphite and refresh my app on my Android phone by pressing the menu button. Sometimes I'll use Mist in the same manner. If the refresh doesn't work successfully, I'll build using the QR code. If the first QR code build doesn't work, I'll delete the app completely from my phone and run the QR code again. I've never used LiveSync with a USB cable.

    Strange thing happened this morning. I changed the build settings to Release instead of Debug, built using the QR code in Graphite, and I got the latest changes so the build worked correctly! I'm unable to refresh the Release build on my phone (that's probably a property of being set to Release) but I did get all my current changes. When I changed the build settings back to Debug and built using the QR code in Graphite, I got an app that's 2 days old. When I refreshed that build, I continued to get the same outdated code on my phone.

    Looks like the issue is related to having Debug set. I'm glad I found a workaround to get my latest changes to my phone by building as Release, but the issue still remains on being able to build and refresh my app using Debug. No errors show up on the build log and it looks like I'm connected because I don't see that broken plug at the top of Graphite and the simulator shows all current code.

    Using HTC Desire 4G (Android 2.3.5) but Samsung Note 2 (Android 4.1.2) doesn't work either.
  4. Steve
    Steve avatar
    11 posts
    Member since:
    Jul 2012

    Posted 26 Jul 2013 Link to this post

    I just migrated your project to target Cordova 2.7 and was able to successfully build your app in Debug and livesync new changes. Please try that and let us know if you encounter any problems.
Back to Top