Bug in GridViewDataColumn check boxes

7 posts, 1 answers
  1. Duncan Bayne
    Duncan Bayne avatar
    9 posts
    Member since:
    May 2010

    Posted 18 Jan 2011 Link to this post

    The default check box behaviour in the Telerik GridViewDataColumn is incorrect. 

    There are no visual cues to distinguish between read-only and writable.  The only way of telling whether the cell is writeable is to click on it.

    I've posted a short video demonstrating the problem here:

    http://www.youtube.com/watch?v=qJrjtzdhExk

    There are clear guidelines for this sort of behaviour in the Windows User Experience Interaction Guidelines (http://msdn.microsoft.com/en-us/library/aa511258.aspx).  In particular, see the example on page 45, which I've reproduced here:

    http://i54.tinypic.com/99m8o7.png

     
  2. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 18 Jan 2011 Link to this post

    Hello Duncan,

     
    Please take a look at the following forum thread.

    Kind regards,
    Vanya Pavlova
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  3. Duncan Bayne
    Duncan Bayne avatar
    9 posts
    Member since:
    May 2010

    Posted 18 Jan 2011 Link to this post

    Vanya,

    Thanks for the suggestion, but I don't see how that forum post is relevant. The issue is not that I can't prevent the user from clicking the checkbox. Setting the IsReadOnly property achieves that.

    My issue is with the fact that the default style of the GridViewDataColumn provides no visual indication of whether the controls in the column are read-only, or not.  They are all greyed out, which contravenes the advice in the Windows User Experience Interaction Guidelines.

    The fix to this would be to alter the default style, so that if the controls only appear greyed-out if they are read-only.

    I have attached a Visual Studio solution that clearly demonstrates the desired behaviour vs. the actual behaviour.  Here is a screenshot:

    http://i55.tinypic.com/jigdnk.png

    Yours,
    Duncan Bayne
  4. Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 20 Jan 2011 Link to this post

    Hello Duncan,

     
    RadGridView uses the standard CheckBox when you are using GridViewDataColumn and GridViewCheckBox in GridViewCheckBox column. In both cases they are gray colored by design when the cell is not in Edit mode.

    To override this behavior you can define a CellTemplate of your data column and put a checkbox in it. You can bind its IsEnabled property to a property of your business object and the states of the checkbox will be the ones that you expect.


    Greetings,
    Vanya Pavlova
    the Telerik team
    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  5. Duncan Bayne
    Duncan Bayne avatar
    9 posts
    Member since:
    May 2010

    Posted 20 Jan 2011 Link to this post

    Vanya,

    Thanks for your reply.  I understand that I can change the styles by editing templates. 

    The issue I'm raising is that the default behaviour - i.e. checkboxes that don't visually distinguish between writable and read-only - is a bug.  It simply doesn't follow the Windows UX guidelines.

    Yours,
    Duncan Bayne
  6. Answer
    Vanya Pavlova
    Admin
    Vanya Pavlova avatar
    2019 posts

    Posted 24 Jan 2011 Link to this post

    Hi Duncan,

    We will further discuss the issue internally with the team.
    In the meantime I have logged your request in our PITS system and you can vote for implementing it in the future following this link.


    Best wishes,
    Vanya Pavlova
    the Telerik team

    Let us know about your Windows Phone 7 application built with RadControls and we will help you promote it. Learn more>>
  7. Duncan Bayne
    Duncan Bayne avatar
    9 posts
    Member since:
    May 2010

    Posted 24 Jan 2011 Link to this post

    Vanya,

    Thanks for following this up :-)

    Yours,
    Duncan Bayne
Back to Top