This is a migrated thread and some comments may be shown as answers.

bottom 1/3 of app cutoff in HTC Evo but works on Nexus 7 and simulator

2 Answers 8 Views
Android Devices
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Alen
Top achievements
Rank 2
Alen asked on 17 Sep 2013, 07:05 PM
Hello,

I'm struggling with an issue where the BOTTOM 1/3 or so of my app is blank when running on the Evo 3D phone (Android 4.0.3). The footer is not visible and the content of the page stops 1/3 up from the bottom yet what's visible is still scrollable. The app works perfectly in the simulator and on my Nexus 7 tablet (Android 4.3). When I rotate the Evo to landscape mode the page then extends to the fills the top and bottom of the screen but then the RIGHT 1/3 of the entire page is blank including the header and footer. I've tried enabling HW acceleration just for grins and no luck. Tried changing the screen manifest settings a bit and no luck. Tried rebooting the Evo and made sure it's as updated as I can get it though Sprint. Any ideas?

BTW, the same app works perfectly when built for iOS and was tested on multiple devices including iPads. Just this one Android phone in my testing so far is having the issue.

I plan to ask more users to Beta test with different devices but wanted to see if anyone else has seen a similar issue first to make sure it's not something easy that I'm missing? The problem makes the app unusable on the device since you can't navigate properly with it in this state.

thanks all,

P. A. Standish

2 Answers, 1 is accepted

Sort by
0
Deyan Varchev
Telerik team
answered on 20 Sep 2013, 11:35 AM
Hi,

 Thanks for contacting us. It looks like a local problem you are experiencing on the HTC device. Can you share with us more details on your case? What UI framework are you using - is it Kendo UI mobile, jQuery Mobile or something else? Which version of the framework are you using (you can look at the .min.js file header for version numbers)? 
Can you provide us with an isolated a simple jsbin demo that shows the problem at hand?
This information will greatly help us reproduce your problem locally and find a solution for it.

Thank you in advance for the collaboration.

Regards,
Deyan Varchev
Telerik

Big news for mobile app and .NET developers! Hear about it at our Release Keynote. Thursday, September 26th, 11AM EDT
Do you enjoy Icenium? Vote for it in Windows IT Pro Community Choice Awards as Best Cloud Computing Product or Service (Category 5).
Looking for tips & tricks directly from the Icenium team? Check out our blog!
Share feedback and vote for features on our Feedback Portal.
0
Accepted
Alen
Top achievements
Rank 2
answered on 31 Oct 2013, 02:50 PM
Deyan,

The Icenium upgrade to letting me use Cordova 3 seems to have resolved the issues. Since I started using that it's been working great. 

thanks!
Tags
Android Devices
Asked by
Alen
Top achievements
Rank 2
Answers by
Deyan Varchev
Telerik team
Alen
Top achievements
Rank 2
Share this question
or