Blend 4 layout refresh problems RadTabControl?

4 posts, 0 answers
  1. Rob Ainscough
    Rob Ainscough avatar
    262 posts
    Member since:
    Jan 2010

    Posted 31 Oct 2011 Link to this post

    Other than Blend 4 being THE worst product on the planet, and VS 2010 not much better.  Is there any way to force Blend 4 to re-draw the layout?

    I'm constantly having "refresh" problems with Rad controls (specifically the RadTabControl and RadGuage) ... I have to exit Blend 4, then come back into Blend 4, load my Project, then select my xaml to be able to see the Rad controls correctly.  Certianly NOT a productivity enhancer ... which I think is supposed to be the goal of using 3rd party controls and SL 4.

    Any suggestions on how to work around Blend 4's problems?

    Thanks, Rob
  2. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3299 posts

    Posted 03 Nov 2011 Link to this post

    Hello Rob Ainscough,

    I am sorry to hear that you experience so much issues while working on your application. And you are indeed right that you should be able to easily customize our controls in Blend. This is why I wanted to ask you to please elaborate on your issues, since we are not aware of problems when configuring/customizing the RadTabControl and the RadGauge control in Expression Blend. In what scenario doesn't Blend refresh the view? What version of ExpressionBlend do you use?

    Also, can you please make sure that your solution can find the Telerik design dlls. They have to be in a design folder inside the directory containing all other referenced Telerik assemblies.

    Looking forward to your reply,
    Tina Stancheva
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Rob Ainscough
    Rob Ainscough avatar
    262 posts
    Member since:
    Jan 2010

    Posted 14 Nov 2011 Link to this post

    I'm using Blend 4 + SketchFlow.  (4.0.20901.0)

    I also have similar problem with Microsoft's DatePicker where the calendar part of the control will remain on the screen even when I select another control.

    The problem with the RadTabControl is that it appears to select the last tab index so I'm constantly reselecting my tab ... this will happen if I look at Data (sample data) in the my Data tab ... as soon as I click on the data tab the selected tab will change to the last tab.

    The same behavior happens on other development computers so I'm pretty sure this isn't an install/hardware issue.

    The only way I can work around this problem is by closing the XAML and re-opening it, but the problem will return as soon as I trigger any of the UI actions that make it happen (like clicking on the Data tab or selecting DatePicker).

    I don't know if this is just a problem with Blend 4 or specific to Telerik, not ALL controls exhibit the problem either, just a few like RadTabControl, DatePicker, RadExpander, RadGuage, and a few others, but NOT all.

    Rob

  4. Tina Stancheva
    Admin
    Tina Stancheva avatar
    3299 posts

    Posted 17 Nov 2011 Link to this post

    Hello Rob,

    Thank you for getting back to us.

    I tested the RadTabControl behavior you described using the same Blend version you noted. But I didn't experience any issues during the tests. Can you please have a look at this screencast and let me know if I'm missing something?

    I also attached the solution I created to test the control. Can you please modify it to better describe your scenario. And if you can send us a screencast demonstrating the behavior with all controls on your side, that would also help us narrow down the cause for the issues.

    Thank you in advance for your cooperation on the matter.

    Best wishes,
    Tina Stancheva
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

Back to Top