Attribute "showTitle" has already been defined

9 posts, 0 answers
  1. Vamshi
    Vamshi avatar
    8 posts
    Member since:
    Jun 2017

    Posted 02 Jun Link to this post

    When I trying to add Telerik DLLs getting this error APT0000:Attribute "showTitle" has already been defined

        I'm using xamarin forms 2.3.4.224

    and xamarin android support libraries 25.1.0.

         I can't added support libraries 23.3.0..because of I'm using Firebase DLL s  its dependencies and xamarin android support libraries should be 25.1.0

        What is the solution?

  2. Lance | Tech Support Engineer, Sr.
    Admin
    Lance | Tech Support Engineer, Sr. avatar
    462 posts

    Posted 05 Jun Link to this post

    Hi Vamshi,

    There is no UI for Xamarin workaround for this. The maximum SDK version Telerik UI for Xamarin (Forms) currently supports is 23.3.0 (we are working on updating this this to Android 7 and is planned for an upcoming release). Please see this documentation for more information.

    One route you can take is to downgrade your version of Firebase to a version that supports 23.3.0, then you can compile both together.

    Alternatively, you can use UI for Xamarin.Android in a Xamarin.Android app instead of a Xamarin.Forms app. We do support Android 7, just not with the Xamarin Forms wrappers yet.

    Regards,
    Lance | Tech Support Engineer, Sr.
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Vamshi
    Vamshi avatar
    8 posts
    Member since:
    Jun 2017

    Posted 06 Jun in reply to Lance | Tech Support Engineer, Sr. Link to this post

    When I using Firebase some of support libraries not found in the version of 23.3.0. Those are available in the version of 24 and 25.
        Those are
           1) Xamarin.Android. support. Compact.dll.
           2)Xamarin. Android.Core.Ui.DLL
           3)xamarin. Android. Support. Udils.dll
           4)xamarin. Android. Fragment.dll
           
    So can't we use telerik and firebase both together..
        Thanks..
         
  4. Tsvyatko
    Admin
    Tsvyatko avatar
    858 posts

    Posted 06 Jun Link to this post

    Hi Vamshi,

    Thank you for sharing this information. Currently, we are working on update to appcompat version 25. The updated is expected to be released by the end of June.

    Regards,
    Tsvyatko
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  5. Tsvyatko
    Admin
    Tsvyatko avatar
    858 posts

    Posted 10 Jun Link to this post

    Hi Vamshi,

    We have identified the exact problem for this issue. Please, check the duplicate thread - http://www.telerik.com/forums/attribute-showtitle-has-already-been-defined

    Regards,
    Tsvyatko
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. Vamshi
    Vamshi avatar
    8 posts
    Member since:
    Jun 2017

    Posted 04 Jul in reply to Tsvyatko Link to this post

     

  7. Vamshi
    Vamshi avatar
    8 posts
    Member since:
    Jun 2017

    Posted 05 Jul in reply to Tsvyatko Link to this post

    I can't find solution....could you explain briefly..
  8. Vamshi
    Vamshi avatar
    8 posts
    Member since:
    Jun 2017

    Posted 05 Jul Link to this post

    Hello,

        When you are releasing updated  telerik DLLs(sdk version 25)...

  9. Lance | Tech Support Engineer, Sr.
    Admin
    Lance | Tech Support Engineer, Sr. avatar
    462 posts

    Posted 05 Jul Link to this post

    Hi Vamshi,

    Please see this answer from Tsvyatko, in your other forum post thread you have going for this topic. He explains that you can use SDK 25, just make sure you are not mixing any v23 support libraries. 

    If you have any further trouble, please reply back in that thread with the problem details instead of here.

    Regards,
    Lance | Tech Support Engineer, Sr.
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top