App Builder Publishes to Itunes but not Google Play

3 posts, 0 answers
  1. Ray
    Ray avatar
    3 posts
    Member since:
    Nov 2014

    Posted 13 Apr Link to this post

    I have an app that is functioning in app builder and showing on simulator fine.

    I have built and distributed to Itunes ok and is currently in Itunes.

    I can build an Android Debug and Release version ok and when I open on my android device it works fine.

    But when I go to Publish for Google Play and build with my valid certificate it comes up Build Failed! Please try to rebuild your application.

    Console errors show two errors:

    1.Build failed during execution

    2.Error: ENOENT: no such file or directory, open 'tmp/builds/qqdzvPKfrWhwitsnZ/app/bin/MyApp.apk'

    at Error (native)


    Can anyone shed some light on what is happening for this build to fail?


  2. Ray
    Ray avatar
    3 posts
    Member since:
    Nov 2014

    Posted 13 Apr Link to this post

    Oh solved it myself, it turns out my old certificate that as coming up valid until 2099 was only a developer certificate, I created a Google Play Certificate valid until 2033 and it worked fine.


    I will leave this here as a reference for others in case they encounter the same issue

  3. Assi
    Assi avatar
    4 posts

    Posted 14 Apr Link to this post

    Hi Ray,

    Thank you for contacting us. We are happy to hear that you resolved the issue by yourself.

    Please let us know if you need any further assistance. 

    Ivomir Assi
    Telerik by Progress

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top