This is a migrated thread and some comments may be shown as answers.

After ugrade of Test Studio to '2013.2.1210.0', my existing tests are broken

1 Answer 13 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Chery
Top achievements
Rank 1
Chery asked on 18 Dec 2013, 04:58 AM

After I have updated my Test Studio to '2013.2.1210.0' , all my existing tests using Telerik.WebAii.Controls.Xaml.Wpf.GridView.Rows[index].Cells method is failing. Now method is able to get only objects (GridViewCell) of Visible columns in the screen. In the previous version it worked well and could get GridCell objects from all the columns, including once that were not visible. Also GridViewCell property Text, which used to work correctly in previous version, is not able to get Text for many of the 'GridViewCell'. It fails with  error "[WPF Extension Error] Details: ArtOfTest.WebAii.Silverlight.NoSuchPropertyException: "

Please find few line of my code for reference,

RadGridView TechnicalQueryGridView = Ts.PIMS.TechnicalIssues.Find.ByAutomationId<RadGridView>("Technical QueryGridView");

 IList<GridViewCell> gCells = TechnicalQueryGridView.Rows[rowNumber].Cells;

foreach (var gCell in gCells)
 {
      Console.WriteLine("Cell Name : " + gCell.Index + ", Cell Text: " + gCell.Text);
 }

Kindly help me, I am totally lost now.

1 Answer, 1 is accepted

Sort by
0
Yordanka
Telerik team
answered on 18 Dec 2013, 02:44 PM
Hello Chery,

Thank you for the feedback.

I've tried to reproduce the problem you report but to no avail. Actually, if column virtualization of RadGridView is turned on (RadGridView.EnableColumnVirtualization="True") only the visible columns are realized on initial loading. The rest of the columns (those outside of the viewport) will be realized once they are scrolled and in viewport. Then you will be able to get the text of the columns. On other side, if the columns virtualization is turned off, all columns will be created on initial load and no need to be scrolled in order to get the text.
Could you check the settings of your grid? Does the case with column virtualization is the reason for the problem? If not, please send us more details about your grid and the exact version of the RadControls for WPF and Test Studio where your tests have been working correctly.

Regards,
Yordanka
Telerik
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
Tags
General Discussions
Asked by
Chery
Top achievements
Rank 1
Answers by
Yordanka
Telerik team
Share this question
or