This is a migrated thread and some comments may be shown as answers.

disable timeslots as per requirement.

3 Answers 33 Views
ScheduleView
This is a migrated thread and some comments may be shown as answers.
hardik
Top achievements
Rank 1
hardik asked on 18 Mar 2011, 10:17 AM
Hi support,

I have earlier post a query related my question at that time a got the answer that my required functionality is available in scheduler view.

Now you have already launch your new product so can you please send me sample application related to my requirement..

I have downloaded trial version.

My requirement is like this.
I want to disable the time slots for different time in a day like 12:00am to 8:00 am and 1 pm to 11 pm are disable for one resource

for another resource12:00 am to 5:00 am and 7:00 am to 11:pm are disable.(See attached image)
I have done this in scheduler using some logic but the problem with it when ever i increase the number of resources than performance of scheduler got decrease.

How can i get better performance with scheduler view.I have used template selector class in scheduler to get my required result.

how is it possible in schedulrView???

Can you please provide me sample application.?This is my first and very important requirement of project.

Thanks
Hardik Pancholi

3 Answers, 1 is accepted

Sort by
0
Yana
Telerik team
answered on 18 Mar 2011, 02:19 PM
Hi hardik,

Please check this help article - it explains in details how to set read-only slots for different resources with different RecurrencePattern.

If you have issues with the approach, do not hesitate to contact us again.

All the best,
Yana
the Telerik team
0
hardik
Top achievements
Rank 1
answered on 19 Mar 2011, 06:04 AM
Thanks for early reply.

I have go through the link you have provided, but i am facing problem with that.I am getting error as shown in Image..Also i attached a image for xaml page.

can you please check it?

If you provide sample application for this "disable multiple time slots for multiple resources" then its good for me.

Is it problem of OS? I have seen one site for target type of style "TargetType="schedulerView:HighlightItem"...
Then there isn't specify anything for win 7..I am using win 7.

http://www.telerik.com/help/wpf/telerik.windows.controls.scheduleview-telerik.windows.controls.highlightitem.html

Thanks
Hardik Pancholi
0
Valeri Hristov
Telerik team
answered on 19 Mar 2011, 12:08 PM
Hello hardik,

Please, replace TargetType="schedulerView:HighlightItem" with TargetType="telerik:HighlightItem" - this should fix the error. Instead of this you could add the following xml namespace to your page:
xmlns:schedulerView="clr-namespace:Telerik.Windows.Controls;assembly=Telerik.Windows.Controls.ScheduleView"

Regards,
Valeri Hristov
the Telerik team
Tags
ScheduleView
Asked by
hardik
Top achievements
Rank 1
Answers by
Yana
Telerik team
hardik
Top achievements
Rank 1
Valeri Hristov
Telerik team
Share this question
or