spell check issue

6 posts, 1 answers
  1. Kirk Quinbar
    Kirk Quinbar avatar
    48 posts
    Member since:
    Nov 2007

    Posted 04 Jan 2011 Link to this post

    we are using Q3 2010 release of telerik. if you take a look at the attached screenshot of our implementation of the richtextbox, you will note some spelling errors indicated by red lines. some of these words make sense that your spellchecker doesnt know them, but some don't. some that are apparently wrong are:

    - "website for" in the first line. why are both words underscored. its like it thinks it one word. website might not be in the dictionary? by "for" should be
    - "or other concerns"
    - "regarding safety"

    all these examples, it seems, should be treated as seperate word checks but they look like they are being evaluated as one word and it cant find that in your dictionary.

    any ideas on what is going on here? bug?
  2. Anthony
    Anthony avatar
    33 posts
    Member since:
    Nov 2010

    Posted 04 Jan 2011 Link to this post

    Please read this article http://www.telerik.com/help/silverlight/radrichtextbox-features-spellcheck.html
    I hope it will help you understand how spelling works in the control.
  3. Kirk Quinbar
    Kirk Quinbar avatar
    48 posts
    Member since:
    Nov 2007

    Posted 05 Jan 2011 Link to this post

    no, that page does not explain the 3 things i was seeing in my example and why those certain words were grouped together like they were.

    Kirk
  4. Answer
    Iva Toteva
    Admin
    Iva Toteva avatar
    1319 posts

    Posted 07 Jan 2011 Link to this post

    Hello Kirk Quinbar,

    We have an idea of what might be causing this problem. Can you confirm that the space between the words is an interval and not a non-breaking space(&nbsp)? That can be done if you show the formatting symbols from the ribbon bar. If the intervals between the problematic words are not marked as dots, that would confirm this theory.
    Some information on the way you are using the rich text box would also be appreciated - for example, are you using a FormatProvider or a DataProvider to populate the document?

    If the problem is what we suspect it to be, we are currently addressing the issue and it will be fixed in the Beta for Q1 or some minor release before that.

    Greetings,
    Iva
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
  5. Kirk Quinbar
    Kirk Quinbar avatar
    48 posts
    Member since:
    Nov 2007

    Posted 07 Jan 2011 Link to this post

    we are using the HtmlDataProvider bound to a property that has html text in it. I just did a test in a little sample app and it looks like i found the same issue you are already working on. I dont know for sure in that screen capture if that text had non-breaking spaces (i'll try and find out), but in my local testing, i can get the spellchecker to underscore perfectly fine words if i put   between them instead of a space.

    can you tie this posting to the work item you have for this issue so i get notified when the fix is in place. we probably have a few instances where sometimes non-breaking spaces were used, so i want to make sure people dont see spelling errors when there really arent any.

    thanks,

    Kirk
  6. Iva Toteva
    Admin
    Iva Toteva avatar
    1319 posts

    Posted 10 Jan 2011 Link to this post

    Hello Kirk Quinbar,

    Thank you for the follow-up. I am creating a PITS issue, where you can track the further development of the issue:
    You can follow the PITS Issue by its ID: 4564 
    Here you can find the PITS Issue: Public URL

    If you have any other questions or comments, do not hesitate to contact us again.

    Greetings,
    Iva
    the Telerik team
    Browse the videos here>> to help you get started with RadControls for Silverlight
Back to Top