Getting Started with Kendo UI for Vue Native Editor

The Editor enables users to create rich textual content through a What-You-See-Is-What-You-Get (WYSIWYG) interface and delivers a set of tools for creating, editing, and formatting of text, paragraphs, lists, and other HTML elements.

The Editor component is part of the Kendo UI for Vue library of Vue UI components. It is distributed through NPM under the kendo-vue-editor package.

The Editor Package is part of Kendo UI for Vue, a professional grade UI library with 90+ components for building modern and feature-rich applications. To try it out sign up for a free 30-day trial.

Basic Usage

The following example demonstrates the Editor in action.

Example
View Source
Change Theme:

Functionality and Features

Installation

  1. Download and install the package. Use Node.js v5.0.0 or later.

    npm install --save @progress/kendo-vue-editor @progress/kendo-vue-intl @progress/kendo-vue-buttons @progress/kendo-vue-dropdowns @progress/kendo-vue-dialogs @progress/kendo-vue-inputs @progress/kendo-vue-layout @progress/kendo-vue-popup @progress/kendo-vue-pdf @progress/kendo-vue-progressbars @progress/kendo-drawing @progress/kendo-licensing
  2. Once installed, import the package module.

    // ES2015 module syntax
    import { Editor, EditorTools } from '@progress/kendo-vue-editor';
    // CommonJS format
    const { Editor, EditorTools } = require('@progress/kendo-vue-editor');
  3. You are required to install one of the Kendo UI for Vue themes to style your components. For more information on how to add the styles, refer to the article on getting started.

  4. Follow the instructions on the Kendo UI for Vue My License page to activate your license. You can skip this step if your application already contains a Kendo UI for Vue license file.

Dependencies

Under the hood, the Kendo UI for Vue Native Editor uses the ProseMirror toolkit. This allows you to utilize the full range of the ProseMirror functionalities and build on top of the existing Editor features.

The Editor package requires the following peer dependencies that have to be installed by your application:

  • vue 2.6.11 or 3.0.0
  • @progress/kendo-drawing
  • @progress/kendo-licensing
  • @progress/kendo-vue-buttons
  • @progress/kendo-vue-dialogs
  • @progress/kendo-vue-dropdowns
  • @progress/kendo-vue-inputs
  • @progress/kendo-vue-intl
  • @progress/kendo-vue-layout
  • @progress/kendo-vue-pdf
  • @progress/kendo-vue-popup
  • @progress/kendo-vue-progressbars