zScaler and Fiddler

10 posts, 0 answers
  1. John
    John avatar
    5 posts
    Member since:
    Jul 2017

    Posted 21 Jul 2017 Link to this post

    I'm getting an error on launching Fiddler.  "Port 9000 is in use by process 'zsatunnel:12596'. Would you like Fiddler to use a random port instead?"

    If I click yes it doesn't capture anything.   I click no and it suggests I manually configure fiddler. I'm not sure how to proceed. Is there a way to configure fiddler to work in this environment? 

  2. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 27 Jul 2017 Link to this post

    Hi John,

    Did you configure the port to be 9000? The default one is 8888. Also can you confirm that when you select "Yes" there is no "Capturing" text in the bottom left corner of Fiddler?

    Usually, this should work as expected - when you select "Yes" it should find an unused port and start capturing.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. Hei
    Hei avatar
    1 posts
    Member since:
    Sep 2017

    Posted 04 Sep 2017 Link to this post

    Hello 

    I am using Zscaler and Fiddler is not working when using Zscaler Agent. Capturing is showing as active.

    I am told that I should configure PAC file to use port 127.0.0.0:8888 and disable loopback and then configure Fiddler proxy settings.

    does anyone have a solution or know about it?

  4. John
    John avatar
    5 posts
    Member since:
    Jul 2017

    Posted 04 Sep 2017 in reply to Alexander Link to this post

    Yeah, I tried that.  But, it keeps changing the port.  I
  5. Alexander
    Admin
    Alexander avatar
    336 posts

    Posted 07 Sep 2017 Link to this post

    Hello,

    Fiddler is a web debugging proxy and as such it has to be proxy for the web traffic in order to capture it. To do that it sets itself as a system proxy on startup. As far as I understand zScaler Agent automatically resets the proxy setting every few seconds which blocks Fiddler from capturing the traffic.

    In order to fix this issue you may have to stop zScaler from changing the proxy settings or set proxy of the zScaler itself. However, this is not a Fiddler-related problem and as such I cannot guide you through this process.

    Regards,
    Alexander
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  6. John
    John avatar
    5 posts
    Member since:
    Jul 2017

    Posted 07 Sep 2017 in reply to Alexander Link to this post

    I was hoping that Fiddler might have the ability to chain the proxies like Charles.

    "On Mac OS X devices, the Zscaler App is interoperable with the web debugging proxy application Charles. If the Charles Proxy is detected, the Zscaler App creates a proxy chain. The Zscaler App automatically configures External Proxy Settings in the Charles application so that the user's system routes all traffic through the Charles Proxy first, then sends the traffic on to the Zscaler App."

    It appears that is not the case or it may be a windows limitations.

  7. Tsviatko Yovtchev
    Admin
    Tsviatko Yovtchev avatar
    549 posts

    Posted 08 Sep 2017 Link to this post

    Well Fiddler does chain proxies but it does that only once on startup. I.e. if there is a proxy set when Fiddler gets started Fiddler will replace that proxy with itself but then it will use that proxy for all outbound traffic.

    If another program changes the proxy settings once Fiddler runs, though, Fiddler won't change them back. 

    In the xscaler/Charles case it looks like zScaler does the chaining and not Charles. zScaler seems to support specifically Charles, though.

    Regards,
    Tsviatko Yovtchev
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  8. John
    John avatar
    5 posts
    Member since:
    Jul 2017

    Posted 08 Sep 2017 in reply to Tsviatko Yovtchev Link to this post

    Seems like an item for the backlog to contact zScaler and ask them to add Fiddler support.  
  9. Sofiane
    Sofiane avatar
    1 posts
    Member since:
    Nov 2017

    Posted 20 Nov 2017 Link to this post

    Have you a solution for this issue ?

    I have the same problem. I have this message in Fiddler: "The system proxy was changed. click to reenable capturing".

    Thanks in advance

  10. John
    John avatar
    5 posts
    Member since:
    Jul 2017

    Posted 20 Nov 2017 Link to this post

    Nope, Fiddler is now useless for me.  I have moved on to using other tools. 
Back to Top