"Your connection is not private" whenever I start Fiddler

12 Answers 14845 Views
Fiddler Classic
Avrohom Yisroel
Top achievements
Rank 1
Avrohom Yisroel asked on 31 Dec 2015, 06:35 PM

Hello,

As soon as I start Fiddler, any attempt to connect to a secure web page fails with the message "Your connection is not private" in my web browser.

What's going on?

 Thanks

12 Answers, 1 is accepted

Sort by
0
Eric Lawrence
Telerik team
answered on 31 Dec 2015, 08:48 PM
Hi, 

This generally indicates that you have enabled HTTPS decryption but haven't configured Windows (or Firefox, if you're using Firefox) to trust Fiddler's root certificate.

The simplest thing to do would be to follow these steps, and when asked if you'd like Windows to trust Fiddler's root certificate, choose "Yes."

http://textslashplain.com/2015/10/30/reset-fiddlers-https-certificates/


Regards,
Eric Lawrence
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Avrohom Yisroel
Top achievements
Rank 1
commented on 31 Dec 2015, 11:37 PM

I'm actually using Chrome, but I checked it in IE as well, and got the same issue. Anyway, I'll give that a go and see what happens.

Thanks

0
Avrohom Yisroel
Top achievements
Rank 1
answered on 04 Jan 2016, 03:47 PM

Turns out the answer was simple. I was using version 2.6.2, whereas I should have been using 4.6.2. I uninstalled, installed the latest and it works fine.

Thanks

Gene
Top achievements
Rank 1
commented on 22 Feb 2016, 11:57 PM

Just installed 4.6.2.0.  Selected to decrypt HTTPS, exported the Fiddler self-signed root, imported it under Windows 7 Trusted Root CA using certmgr.msc, and verified Windows trusts it.  Then imported it into Firefox 44.0.2 Advanced > Certificates > View Certificates > Authorities with Trust Setting to Identify Websites.  Every https reference when Fiddler is running, regardless of browser, gives "Your connection is not secure" error.  If I close Fiddler, no errors.  Rebooted, no change.  Not sure what I'm doing wrong.

TIA, Gene

0
Tsviatko Yovtchev
Telerik team
answered on 25 Feb 2016, 03:40 PM

Hello,

Could you, please, try following these steps:

  1. Click Tools > Fiddler Options.
  2. Click the HTTPS tab.
  3. Ensure that the text says Certificates generated by CertEnroll engine.
  4. Click Actions > Reset Certificates. This may take a minute.
  5. Accept all prompts


Regards,

Tsviatko Yovtchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Gene
Top achievements
Rank 1
commented on 25 Feb 2016, 06:42 PM

Thank you Tsviatko.  After executing the steps you provided (and importing the new cert into Firefox), all https requests work properly from all browsers, and Fiddler is properly capturing.

Can you tell me what the problem was, and what may have caused it?

Tsviatko Yovtchev
Telerik team
commented on 01 Mar 2016, 06:09 PM

Hi,

Well Fiddler has upgraded certificates infrastructure. This - http://textslashplain.com/2015/10/30/reset-fiddlers-https-certificates/ (also mentioned previously) explains it.

Regards,
Tsviatko Yovtchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Neyla
Top achievements
Rank 1
commented on 08 Jun 2018, 11:06 PM

I have Fiddler installed on my machine. I have installed the Fiddler Root Certificate to decrypt HTTPS traffic, but it only works in FF and IE, not in chrome. Chrome does not trust Fiddler's certificate and does not allow me to connect to any tunneled connections.
I tried looking on Fiddler2.com's page for a plugin but I don't see anyhing.

Neyla
Top achievements
Rank 1
commented on 10 Jun 2018, 03:08 PM

I have Fiddler installed on my machine. I have installed the Fiddler Root Certificate to decrypt HTTPS traffic, but it only works in FF and IE, not in chrome. Chrome does not trust Fiddler's certificate and does not allow me to connect to any tunneled connections.
I tried looking on Fiddler2.com's page for a plugin but I don't see anyhing https://bluestacks.vip/  https://textnow.vip/    https://photomath.vip/
Alexander
Telerik team
commented on 12 Jun 2018, 06:43 AM

Hi,

Which version of Chrome are you using? Also, would it be possible to navigate to a page, where Chrome says "Your connection is not private", hit F12 and go to the Security tab? There shoould be some information why the certificate is not trusted.

Regards,
Alexander
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Bashar
Top achievements
Rank 1
commented on 09 Sep 2018, 11:39 PM

I did all steps But!

This page is not secure (broken HTTPS).
Certificate - insecure (SHA-1)
The certificate chain for this site contains a certificate signed using SHA-1.
View certificate

Certificate - Subject Alternative Name missing
The certificate for this site does not contain a Subject Alternative Name extension containing a domain name or IP address.
View certificate

Certificate - missing
This site is missing a valid, trusted certificate (net::ERR_CERT_COMMON_NAME_INVALID).
View certificate
===================================

Chrome : 68.0.3440.106 (Official Build) (32-bit)

Fiddler Https Interface : https://i.imgur.com/c5GKSNl.png

 

Barry
Top achievements
Rank 1
commented on 02 Feb 2020, 07:03 PM

i think something is wrong with the SSL certificate  

Bradley
Top achievements
Rank 1
commented on 03 Feb 2020, 08:17 AM

Im having the same error.

Are you using centralised certs by any chance?

Carlton
Top achievements
Rank 1
commented on 02 Nov 2020, 08:18 PM

I have followed the documentation and exported the fiddler cert to my machine, did the trust certificate through windows cert management and then in Settings for Chrome and Firefox I added the cert but still I get security denial when hitting any https site with Decrypt HTTPS traffic checked. jiofi.local.html forpc

0
Keith
Top achievements
Rank 1
answered on 06 May 2017, 12:58 AM
Gotcha I ran into:  resetting Windows Root Certs did not work, turns out I still had the old CertMaker DLL installed.  Uninstalled the old CertMaker plugin, noticed Fiddler certs are now generated by CertEnroll, reset Root Certs, and voila.

Thorny problem that caused a wonky error:  Outlook would disconnect from Exchange whenever Fiddler was not running (even if traffic capture was turned off).
tech
Top achievements
Rank 1
commented on 29 Mar 2022, 10:52 AM

Thanks for sharing this information. for pc
0
Jitendra
Top achievements
Rank 1
answered on 25 Oct 2017, 09:14 AM

Here is how to fix Your Connection is Not Private Error In Chrome
One of the main reasons behind such an error may be the wrong date and time settings. The SSL might fail to fetch data from the server when an inaccurate date is provided. To change them, go to Date and Time under Settings in your system, and choose the option Set Time Automatically. This helps in securing loading of data.
Slide the bar below Set Time Automatically to turn it on.This lets the system to fetch time directly from the network, thus providing accurate measures.
Source:- http://merabheja.com/connection-not-private-error-in-chrome/
soanl
Top achievements
Rank 1
commented on 24 Apr 2018, 04:46 PM

Lots of thanks for sharing this amazing article and i think you know about lucky patcher apk free download it works fine. For info visit @ https://luckypatcherapkhub.com/download-lucky-patcher/
0
Lairger
Top achievements
Rank 1
answered on 28 Jun 2018, 07:36 AM

Fiddler normally is a valid network analysis tool, but I hope some malware/virus did not auto-install it with an invalid root cert for bad purposes.  Have you run an antivirus scan on your computer?

To remove any untrusted certificates from your Windows computer, try the following:

  1. Click Start, type certmgr.msc in the search box and press Enter.
  2. In the left panel, navigate to Untrusted Certificates and then expand Certificates.
  3. Right click on the certificates you wish to remove and choose Delete.
0
Hare
Top achievements
Rank 1
answered on 13 Jul 2018, 07:11 AM
This feature works by periodically checking whether Fiddler is running, and automatically adjusting the proxy settings based on that check. If you click on the status bar panel, a popup menu enables you to change your FiddlerHook settings.
0
Nick Iliev
Telerik team
answered on 03 Nov 2020, 10:06 AM

Hi Carlton,

 

The "Your connection is not private" screen might appear due to multiple reasons that could not be strictly related to Fiddler. I've tried the provided HTTPS endpoint, and it is captured directly with no hassle on my side.

HTTP/1.1 200 OK
Date: Tue, 03 Nov 2020 09:56:40 GMT
Server: Apache
X-UA-Compatible: IE=edge
Link: <https://jiofilocalhtml.run/wp-json/>; rel="https://api.w.org/", <https://jiofilocalhtml.run/wp-json/wp/v2/pages/6>; rel="alternate"; type="application/json", <https://jiofilocalhtml.run/>; rel=shortlink
Upgrade: h2,h2c
Connection: Upgrade, Keep-Alive
Vary: Accept-Encoding
Content-Length: 41149
Keep-Alive: timeout=5, max=75
Content-Type: text/html; charset=UTF-8

I would suggest checking the points listed here (especially the ones about the computer clock, the expired TSL, clearing the browser cache, trying incognito).

 

If you still have the issue, you could also try the new Fiddler Everywhere and see if the automatic certification installation works on your side (for example, through Fiddler Everywhere and Chrome).

 

Regards,
Nick Iliev
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
alex
Top achievements
Rank 1
answered on 01 Mar 2021, 07:46 PM
It happens when to try to browse the website which has no security plugin or certificate, to prevent this error you need to install SSL certificate on your website. Furthermore you can check this guide it will help you: https://www.cloudways.com/blog/wordpress-ssl/
0
alex
Top achievements
Rank 1
answered on 15 Mar 2021, 08:15 PM
It happens when you are visiting a website which is not secure of don't have SSL installed, Checkout this guide to learn more about Fixing this error: https://www.cloudways.com/blog/wordpress-ssl/
0
Monika
Top achievements
Rank 2
Iron
answered on 15 Oct 2021, 07:29 AM
This feature works by periodically checking whether Fiddler is running, and automatically adjusting the proxy settings based on that check. If you click on the status bar panel, a popup menu enables you to change your FiddlerHook settings. Login to JioFi Admin Panel using jiofi.local.html with the default Username and Password given on the Box.
Izwa
Top achievements
Rank 1
commented on 26 Oct 2021, 05:21 PM

I am using so many users' data in my website and database. Will it cause any issue when I use Fiddler on my web platform? The answer will be much appreciated. I need a direct answer. Please answer me.
Nick Iliev
Telerik team
commented on 27 Oct 2021, 06:18 AM

Could you elaborate more on how you plan to use Fiddler on your web platform? If you are thinking of using it as a 24/7 service to monitor the traffic - then it is probably not a good idea as it is a UI tool meant for debugging and not for non-stop monitoring (FiddlerCore is the library you could use to create your own app to achieve that)
0
Carlton
Top achievements
Rank 1
Iron
answered on 22 Dec 2021, 08:50 AM | edited on 22 Dec 2021, 10:11 AM
1. Open Chrome.

2. Press CTRL + SHIFT + N keys together from your keyboard to open chrome in incognito mode and try opening the website again.


tech
Top achievements
Rank 1
commented on 09 Mar 2022, 01:05 PM | edited

I think something is wrong with the SSL certificate.

Tags
Fiddler Classic
Asked by
Avrohom Yisroel
Top achievements
Rank 1
Answers by
Eric Lawrence
Telerik team
Avrohom Yisroel
Top achievements
Rank 1
Tsviatko Yovtchev
Telerik team
Keith
Top achievements
Rank 1
Jitendra
Top achievements
Rank 1
Lairger
Top achievements
Rank 1
Hare
Top achievements
Rank 1
Nick Iliev
Telerik team
alex
Top achievements
Rank 1
Monika
Top achievements
Rank 2
Iron
Carlton
Top achievements
Rank 1
Iron
Share this question
or