This is a migrated thread and some comments may be shown as answers.
Windows 10 Universal Mail App cannot be captured
2 Answers 8 Views
This is a migrated thread and some comments may be shown as answers.
Najib
Top achievements
Rank 1
Najib asked on 20 Oct 2017, 05:10 PM
Hi there, I'm trying to capture traffic on a Windows 10 from the universal mail app. I followed the app container procedure however when I start capturing a press the sync button in the mail app, the app just keeps showing the loading animation over and over. As soon as I close fiddler the mail app manages to sync. Can anyone confirm this behaviour and perhaps have a solution? Thanks.

2 Answers, 1 is accepted

Sort by
0
Accepted
Simeon
Telerik team
answered on 26 Oct 2017, 12:40 PM
Hello,

I managed to reproduce your issue.

Firstly, could you please, confirm that you have configured Fiddler to work in buffering mode (the default) which buffers the response before sending it to the client and also that you have enabled the decryption of the HTTPS traffic.

If this is the case, it seems that the server for the mail client is streaming the response and Fiddler by default does not forward it to the client until it receives it all. Hence, the mail client does not receive the response.

The solution is to enable the Streaming Mode by clicking on the 'Stream' button on the toolbar. This makes Fiddler forward any response data to the client immediately.

Regards,
Simeon
Progress Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Najib
Top achievements
Rank 1
answered on 26 Oct 2017, 06:20 PM

Hi Simeon,

Yes that in fact worked! Thanks for the feedback!

Asked by
Najib
Top achievements
Rank 1
Answers by
Simeon
Telerik team
Najib
Top achievements
Rank 1
Share this question
or