Webaii Broken ?

2 posts, 0 answers
  1. Jay
    Jay avatar
    7 posts
    Member since:
    May 2010

    Posted 09 Jun 2010 Link to this post

    Hey Guys,

    I recently downloaded the new version of Webaii Dev Edition. What this has done is added a Data Folder to my Visual Studio 2008 (SP1) Solution.

    In There it has created various .dbsrc files  ( i am using a Data Driven Excel SpreedSheet).

    When i Try to Run any Test i Get The following:

    Overall Result: Fail
    '09/06/2010 10:38:58' - Execution Stage:Init , unexpected error during test execution. Error: System.ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.
       at System.Data.Common.DbProviderFactories.GetFactory(String providerInvariantName)
       at ArtOfTest.Common.Design.Data.DbDataSource.GetData(DataInfo testBindingInfo)
       at ArtOfTest.WebAii.Design.Execution.ExecutionContext.InitializeDataSource(String outDirectory)
       at ArtOfTest.WebAii.Design.Execution.ExecutionContext.SetCurrentTest(Test test)
       at ArtOfTest.WebAii.Design.BaseWebAiiTest.Initialize(Test testcase, Settings settings, String deploymentDirectory, ExecutionType exeType)
       at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(Test test, Settings settings, String deploymentFolder, ExecutionType exeType)
    '09/06/2010 10:38:58' - Overall Result: Fail

    Any Help would be greatly Appreciated.

  2. Cody
    Cody avatar
    3354 posts

    Posted 09 Jun 2010 Link to this post

    Hello John Bird,

    What version did you upgrade from and what version did you upgrade to? Did you try to re-bind your data driven test? If that doesn't work can you send us the entire project put into a .zip file for us to diagnose?

    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Back to Top