WCF activation made Teampulse fail

Thread is closed for posting
5 posts, 1 answers
  1. Raquel
    Raquel avatar
    21 posts
    Member since:
    Dec 2011

    Posted 13 Mar 2012 Link to this post

    We had a problem with our TeamPulse installation, and we can't use it now.

    We installed the windows feature "WCF Activation" at our server and TeamPulse stopped working at all (The web page didn't load).

    We removed the feature again, and it still doesn't work, it starts loading now, but we have this error:

    Exception Type: System.Reflection.TargetInvocationException
    Exception Message: [Async_ExceptionOccurred]
    Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.0.61118.00&File=System.dll&Key=Async_ExceptionOccurred
       at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
       at TeamPulse.Client.AuthorizationService.GetUserLicenseInfoCompletedEventArgs.get_Result()
       at TeamPulse.Client.App.GetUserLicenseInfoCompleted(Object sender, GetUserLicenseInfoCompletedEventArgs e)
    (Inner Exception)
    Exception Type: System.ServiceModel.ProtocolException
    Exception Message: [ResponseContentTypeMismatch]
    Arguments: text/html; charset=utf-8;text/xml; charset=utf-8;1024;
    <!doctype html>
    <!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
    <!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
    <!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
    <!--[if gt IE 8]><!-->
    <html class="no-js" lang="en">
    <head id="Head1" runat="server">
        <meta charset="utf-8" />
        <link href="/Content/Site.css" rel="stylesheet" type="text/css" />
        <meta name="viewport" content="width=device-width,initial-scale=1" />
        <div id="Wrapper" style="padding: 50px; background: #fff; border-radius: 3px; margin: 10px;">
    <div id="Body">
                An error occurred while processing your request
            <p>Try one of these options:</p>
                <li>Re-type the address</li>
                <li><a href="javascript: history.go(-1);">Go back to the previous page</a></li>
    Debugging resource strings are unavailable. Often the key and arguments provide sufficient information to diagnose the problem. See http://go.microsoft.com/fwlink/?linkid=106663&Version=5.0.61118.00&File=System.ServiceModel.dll&Key=ResponseContentTypeMismatch
       at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
       at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.TeamPulseAuthorizationServiceClientChannel.EndGetUserLicenseInfo(IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.TeamPulse.Client.AuthorizationService.ITeamPulseAuthorizationService.EndGetUserLicenseInfo(IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.OnEndGetUserLicenseInfo(IAsyncResult result)
       at System.ServiceModel.ClientBase`1.OnAsyncCallCompleted(IAsyncResult result)
  2. Raquel
    Raquel avatar
    21 posts
    Member since:
    Dec 2011

    Posted 15 Mar 2012 Link to this post

    Hello again,

    We still can't use TeamPulse at all, I've told my boss to open a support ticket. 

    About that, is there any way I could create and manage TeamPulse support  tickets without access to the company account? I think is quite common that the person that uses and manages a tool is an employee and the telerik account used to buy the products belongs to the company and, of course, they don't want us to use it.
  3. Answer
    Oleg avatar
    44 posts

    Posted 15 Mar 2012 Link to this post

    Hello Raquel,

    We reproduced your problem and this appears to be an issue related to IIS and .Net Framework 4.0 - caused by the installation of WCF Http Activation Module (version 3.0) over them.

    Please try to register the correct version of ASP.NET on your server machine. 
    To do that you can use the commant prompt (run it as admin) - navigate to C:\Windows\Microsoft.NET\Framework\ v4.0.30319 and run the following command:

    aspnet_regiis.exe -iru

    That should allow you to use TeamPulse even without the need of uninstalling WCF.

    As for your question on managing support tickets without access to the company account - this is possible. For that purpose the owner of the company account needs to navigate to http://www.telerik.com/account/licensed-developers.aspx and create an additional licensed user with the desired permissions.

    I hope this solves your problem. Let us know if there are any further issues with your TeamPulse instance.

    All the best,
    the Telerik team
  4. Raquel
    Raquel avatar
    21 posts
    Member since:
    Dec 2011

    Posted 15 Mar 2012 Link to this post

    Thank you! It worked instantly and we can work with TeamPulse again.

    About the ticket management question, we have tried what you told us, but it says that we can't add more users (See attached screenshot). It says we have 1 of 1 licensed users, but we have 6 TeamPulse licenses.  Is it possible that something is wrong here or we can't do this with out current license situation?
  5. Oleg
    Oleg avatar
    44 posts

    Posted 16 Mar 2012 Link to this post

    Hello Raquel,

    I am glad to hear that the problem is solved.

    We will send a response to the account owner to discuss possibilities for adding additional support users to your license.

    the Telerik team
Back to Top