Visual Studio 2017 Test Explorer not showing Telerik tests

5 posts, 1 answers
  1. aplicaciones
    aplicaciones avatar
    34 posts
    Member since:
    Apr 2017

    Posted 13 Mar Link to this post

    Hello,

    My scenario is the following one:

    I am migrating my development Environment to a new one.
    On machine A: I have VS 2015 with Telerik Test Studio ( I have deactivated the license and using the trial for transitioning purposes)
    On machine B: I have VS 2017 with Telerik Test Studio ( I have now transitioned the license to this machine)

    The Telerik Test Studio version is 2017.3 on both machines and I am not planning to update to the most recent version unless is strictly necessary. 
    There are no issues with the license. 

    I struggled a little but I managed to Install the Visual Studio PLugin thanks to Elena Tsvetkova's post:
    https://www.telerik.com/forums/installing-visual-studio-plugin-for-vs2017

    But the Test Explorer is not showing the Telerik tests in VS 2017while on VS 2015 I see them perfectly.
    I have attached an Image showing the difference.

    On VS 2017 I see this in the Test  Output pane:
    [13/03/2018 15:39:00 Error] Microsoft.TestPlatform.VsTestConsole.TranslationLayer.TransationLayerException: Error connecting to Vstest Command Line
       at Microsoft.TestPlatform.VsTestConsole.TranslationLayer.VsTestConsoleWrapper.EnsureInitialized()
       at Microsoft.TestPlatform.VsTestConsole.TranslationLayer.VsTestConsoleWrapper.InitializeExtensions(IEnumerable`1 pathToAdditionalExtensions)
       at Microsoft.VisualStudio.TestWindow.TestPlatformV2.TestPlatformV2Wrapper.UpdateExtensions(IEnumerable`1 pathToAdditionalExtensions, Boolean loadOnlyWellKnownExtensions)
       at Microsoft.VisualStudio.TestWindow.Controller.TestPlatformProvider.UpdateTestPlatform(Lazy`1 testPlatform)
       at Microsoft.VisualStudio.TestWindow.Controller.TestPlatformProvider.GetTestPlatformV2()
    [13/03/2018 15:39:00 Informational] ========== Discover test finished: 0 found (0:01:00,5346965) ==========

    But on the other hand, I have no issues at all on VS 2017 to see normal Unit Tests.

    I would appreciate if you could point me in the right direction as I am not finding a way to sort this out.

     

    Regards,
    Sebasitian

     

     



  2. Answer
    Nikolay Petrov
    Admin
    Nikolay Petrov avatar
    308 posts

    Posted 14 Mar Link to this post

    Hi,

    Please note that it is necessary to have VS 2017 Professional or higher edition.

    If re-building the project do you have still the tests missing?

    After you installed the "Testing Tools Core Feature" component I suggest trying to re-install the Test Studio on the machine. When installing the product verify that the Test Studio VS 2017 plugins will be installed as well.
    After the installation verify that all of the plugins are present. Please refer to the attached screenshot.

    I hope this will resolve the problem.

    Best Regards,
    Nikolay Petrov
    Progress Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
  3. aplicaciones
    aplicaciones avatar
    34 posts
    Member since:
    Apr 2017

    Posted 14 Mar in reply to Nikolay Petrov Link to this post

    Thank you soooo much Nikolay :D
    After re-installing Test Studio have successfully discovered my tests :D

    Regards,
    Sebastian
  4. Khushbu
    Khushbu avatar
    1 posts
    Member since:
    Jun 2017

    Posted 16 Aug in reply to Nikolay Petrov Link to this post

    Thank you. This option works.
  5. Elena Tsvetkova
    Admin
    Elena Tsvetkova avatar
    938 posts

    Posted 17 Aug Link to this post

    Hello Khushbu,

    Glad to know that post helped you as well! 

    Regards,
    Elena Tsvetkova
    Progress Telerik
     
    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
     
Back to Top