Visual Studio 2012 doesn't apply changes unless I clean / rebuild the solution first

Thread is closed for posting
2 posts, 0 answers
  1. Saverio
    Saverio avatar
    1 posts
    Member since:
    Sep 2013

    Posted 13 Sep 2013 Link to this post

    I've stumbled upon a really annoying issue with Visual Studio 2012. 

    Scenario: I am developing a Windows Phone 8 App, in C#, with Telerik RedControls wizard. 
    If I apply a change to the XAML and press F5 / Build and Launch / Launch the emulator or Device it won't reflect the changes I did. In order to make the changes show, I have to either Clean or Rebuild the project before launching it. 

    This doesn't seem to happen with an empty project (C# / WP8) without Telerik, but the same problem happened also in the past in other projects, possibly it might be linked to referincing DLLs, but it doesn't always happen when referencing DLLs either (SQLite didn't seem to cause issues in another previous project).

    Browsing the net I tried all the steps provided in what I found on StackOverflow and other websites: 
    1) Tools >> Options >> Project and Solution >> Build and Run >> Check that "On run, when projects are out of date" is set to "Always build" or "Prompt to build" 
    2) Build >> Configuration Manager >> Check that "Build" is checked for all of the projects you want to build for each of the configurations you need to use. 
    3) I tried Setting the Build option's platform to Any CPU / x86 / ARM but the result is always the same 

    This is extremely annoying because I am unable to code & see the effects, and sometimes I don't know if something is working or not cause of this.

    If I had to take a guess it might be something related to the references added by Telerik (in this case), but I am really at a loss of solutions.

  2. Deyan
    Deyan avatar
    2147 posts

    Posted 18 Sep 2013 Link to this post

    Hello Saverio,

    As discussed in the support thread you have opened regarding the same case, the reason for this behavior seems to be the name of the project. If you create a Windows Phone app project in Visual Studio that has whitespaces in its name, Visual Studio won't track the changes in source files correctly and when you press F5 to launch the project, the changes won't be reflected.

    Make sure you create projects with names without whitespaces to avoid this behavior.

    Have a suggestion or face a problem - you can use the Ideas & Feedback portal to submit ideas, feedback and vote for them.
Back to Top