Unable to run simulator - Cannot find the file specified

Thread is closed for posting
3 posts, 0 answers
  1. Delphi
    Delphi avatar
    11 posts
    Member since:
    Mar 2015

    Posted 08 Oct 2015 Link to this post

    I was running the AppBuilder simulator from Visual Studio earlier to take a few screenshots.

    I wanted to clear my local storage so I renamed the AppData\Local\Telerik\BlackDragon\Cache\WebBrowserPackage-2015.3.1001.1\WebBrowserCache\Local Storage folder to Local StorageOld.

    I then ran the simulator and took some more screenshots for iPhone 6 Plus and then iPhone 6.

    I changed to iPhone 5 configuration and the Simulator exited and since then I have not been able to run the simulator. I have tried restarting visual studio after deleting the %LocalAppData%/Telerik/BlackDragon folder, but that did not work.

     I also tried deleting the %LocalAppData%/Telerik folder and that also has not worked.

     The message that I get if I try to launch the simulator for any project is

    [2015-10-09 13:28:44.375] Log (Exception,High): System.ComponentModel.Win32Exception (0x80004005): The system cannot find the file specified
       at System.Diagnostics.Process.StartWithCreateProcess(ProcessStartInfo startInfo)
       at System.Diagnostics.Process.Start()
       at System.Diagnostics.Process.Start(ProcessStartInfo startInfo)
       at Telerik.BlackDragon.Client.Mobile.Simulator.Services.SimulatorService.<RunSimulatorAsync>d__2.MoveNext()
    --- End of stack trace from previous location where exception was thrown ---
       at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
       at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
       at Telerik.BlackDragon.Client.Simulator.RunInSimulatorMenuCommandBase.<RunSimulatorAsync>d__0.MoveNext()

  2. Ventsislav Georgiev
    Ventsislav Georgiev avatar
    20 posts

    Posted 09 Oct 2015 Link to this post


    Thank you for contacting us.

    The message you are receiving means the Device Simulator executable is missing. The Device Simulator is part of the AppBuilder Visual Studio Extension installation, so I suggest you to reinstall the AppBuilder Visual Studio Extension to restore its missing files.

    Let me know if that helps.

    Ventsislav Georgiev

    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

  3. Delphi
    Delphi avatar
    11 posts
    Member since:
    Mar 2015

    Posted 11 Oct 2015 Link to this post

    Yes, that worked.


Back to Top