This is a migrated thread and some comments may be shown as answers.

Unable to record/run tests in Firefox 30.0

6 Answers 23 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Anna
Top achievements
Rank 1
Anna asked on 02 Jul 2014, 09:09 PM
Hello,

I recently downloaded a trial version of Test Studio and I'm having trouble getting the record and run functions to work in Firefox 30.0. IE, Chrome, and Safari all work perfectly, but Firefox does not run. I've read all of the tutorials I can find to fix this problem, but have had no luck in getting it to work. My extensions appear to be properly enabled. I've tried uninstalling and reinstalling both Firefox and Test Studio multiple times. My registry keys are all pointing to the correct place. But I am still unable to record and run tests.

I've attached a screenshot of the window that pops up in Firefox when I try to record and run tests. If someone could help me with this problem, I would be very grateful.

Also, when I click on the Exploratory Tool (the purple icon that was added with the extensions), I get an error message saying 'Cannot launch Telerik Exploratory Tool'. Is this connected to the problem I am currently having.

Thanks in advance,
Anna

6 Answers, 1 is accepted

Sort by
0
Ivaylo
Telerik team
answered on 07 Jul 2014, 12:15 PM
Hello Anna,

I cannot see from your screenshot if the recorder is properly attached in the bottom. 
We have a known issue with Symantec Antivirus Protection preventing from our extension to attach properly. You may take a look and disable any antivirus program and turn off any firewall that you are using.

Just for testing purposes are you getting the same behavior using another machine?

Looking forward to hearing from you.

Regards,
Ivaylo
Telerik
 
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
 
0
Anna
Top achievements
Rank 1
answered on 09 Jul 2014, 10:09 PM
Hi Ivaylo,

I do not see a recorder on the bottom of my Firefox browser when I'm trying to record. It should be similar to the recording toolbar in Chrome, right? I tried disabling my antivirus programs and firewall, but nothing changed.

I installed Test Studio on another machine and I am encountering the same problem with Firefox.

I'm really don't know what the problem is. Do you have any other suggestions?

Thanks,
Anna
0
Ivaylo
Telerik team
answered on 14 Jul 2014, 08:37 AM
Hello Anna,

Could you please provide me with a screen shot of the extensions. They should look exact the same way as in my screen shot attached in this ticket.

To be honest I am out of ideas what might be causing this, are both machines you are using in the same domain/network? A higher level policy may apply in this case. You may try the behavior out of your company environment.

Looking forward to hearing from you.

Regards,
Ivaylo
Telerik
 
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
 
0
Es
Top achievements
Rank 1
answered on 22 Aug 2014, 12:29 PM
Hello there,

I'm having the same problem with Firefox. I'm trying to record a web test with firefox but If I try to click record and select firefox, test studio is not opening the browser and closing itself. IE and Chrome is opening properly. Do you have any idea?
0
Es
Top achievements
Rank 1
answered on 22 Aug 2014, 12:31 PM
My OS Win 8.1, Firefox 31.0, I don't have any antivirus extensions.
0
Ivaylo
Telerik team
answered on 27 Aug 2014, 06:34 AM
Hello Es,

Please clear the application log, reproduce the behavior and send it over so I can investigate further.

Please also make sure you are running the latest version of Test Studio.

Looking forward to hearing from you.

Regards,
Ivaylo
Telerik
 
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
 
Tags
General Discussions
Asked by
Anna
Top achievements
Rank 1
Answers by
Ivaylo
Telerik team
Anna
Top achievements
Rank 1
Es
Top achievements
Rank 1
Share this question
or