Unable to play my first test

4 posts, 1 answers
  1. Ko-Lin
    Ko-Lin avatar
    8 posts
    Member since:
    Oct 2010

    Posted 01 Nov 2010 Link to this post

    Hi, 

      I am unable to play my tests via quick execute nor via test view.  Below is my test environment and attached are the screenshots for both test execution methods.

    Downloaded and installed WebUI Dev trail version today and -
    I am using Windows 7 64-bit + VS2010 (ran as Administrator) + IE8 with settings recommended by Art of Test.
  2. Answer
    Keaegan
    Admin
    Keaegan avatar
    126 posts

    Posted 03 Nov 2010 Link to this post

    Hi Ko-Lin,


    First thing we should do is confirm that IE is configured correctly (both browser settings and add-ons) using the following link.

    Confirm IE 7/8 Browser Settings

    After you confirm your browser is setup correctly, re-test the issue. If it is still occurring, please make sure you are only running WebUI Studio Add-ons for now. To pull up the Manage Add-ons window, use the following link to review steps from Microsoft on both IE7 and IE8. Once you have the Manage Add-ons window open, disable all add-ons are deleted except for the two listed below.

    Manage Add-Ons IE 7/8:

    (Make sure that the only active Add-ons within IE are disabled except)
      • WebUI TestStudio Recorder
      • WebAii Test Execution Extension

     


    If the above does not resolve this for you, can you confirm if you are able to record a new test using the built in record feature and quick execute it (no coded steps in a test)? Doing so will give us further data on the full impact of this issue within your environment.


    Also, for when you are running your tests out of the VS Test View, check that Deployment is checked within the test settings (it is un-checked by default in VS 2010). To confirm this setting is active:
    1. Open VS 2010
    2. Bring up your project/solution
    3. In the Solution Explorer, double-click local.testsettings to bring up the test settings for this project/solution
    4. Click Deployment on the left column
    5. Check the box for Enable Deployment

    This setting only impacts tests if they are run from "Test View", so it should not impact your issue with "Quick Execute" that you are currently having.

    We'll look for your reply with the above data. 

    All the best,
    Keaegan
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Ko-Lin
    Ko-Lin avatar
    8 posts
    Member since:
    Oct 2010

    Posted 07 Nov 2010 Link to this post

    Hi,

      Thank you for your checklist, I am now able to play my tests.  I found my WebAii Test Execution Extension is somehow disabled and I haven't set the deployment on local.testsettings. 


  4. Keaegan
    Admin
    Keaegan avatar
    126 posts

    Posted 08 Nov 2010 Link to this post

    Hi Ko-Lin,

    Please remember that the Enable Deployment checkbox is disabled by default on all new projects/solutions in VS 2010, so you will need to check the box again if you make a new project.

    All the best,
    Keaegan
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top