Unable to find silverlight elements

3 posts, 0 answers
  1. dileep
    dileep avatar
    9 posts
    Member since:
    Jun 2010

    Posted 25 Jun 2010 Link to this post

    Hello Nelson,
    How are u ? iam sending screeshot plez check it .
    I am just exporing on the issue bec in future the whole poject have to
    automate in telerik plez do u best the below is error it is showing
    1)version iam using is vsts 2008


    '6/25/2010 2:49:17 AM' - 'Fail' : 24. Click Item10Hyperlinkbutton
    --------------------------------------------------
    Failure Information:
    ~~~~~~~~~~~~~~~
    Unable to locate element. Details: Attempting to find [Silverlight] element using
    Find logic
     (Html): [id 'Exact' silverlightControlHost] THEN UNDER NODE FIND [tagIndex 'Exact' object:0]
     (Silverlight): [XamlTag 'Exact' gridviewvirtualizingpanel] AND [automationid 'Exact' PART_GridViewVirtualizingPanel] THEN UNDER NODE FIND [XamlPath 'Exact' /gridviewrow[6]/grid[name=grid]/datacellspresenter[name=PART_DataCellsPresenter]/stackpanel[0]/horizontalscrollpanel[name=PART_PartialScrollContainer]/gridviewcellspanel[name=PART_GridViewCellsPanel]/gridviewcell[1]/grid[name=SelectionBackground]/alignmentcontentpresenter[name=PART_ContentPresenter]/grid[0]/hyperlinkbutton[0]]

    Unable to locate element. Search failed!

    --------------------------------------------------
    '6/25/2010 2:49:17 AM' - Detected a failure. Step is marked 'ContinueOnFailure=False' aborting test execution.
    --------------------------------------------------
    '6/25/2010 2:49:19 AM' - Overall Result: Fail


    regards
    Dileep.s

    --------------------------------------------------



     
  2. Missing user
    Missing user avatar

    Posted 25 Jun 2010 Link to this post

    Hello dileep,

    Since this looks like a topic you posted in another ticket, please reply back to only one ticket for any single topic and do not create a new one so that it will be easier to track the issue, read all the relevant posts and reply back.

    Also, since you are using WebUI Test Studio Dev Edition, please select the product as WebUI Test Studio Developer Edition for the ticket.

    Again, if you can please confirm that you added the PopupTracker.Track() to your Silverlight ChildWindow as in this blog.

    If you did add the PopupTracker.Track() to your Silverlight app, is WebUI picking up the recording over the Child Window as far as typing and clicking on the controls in the Child Window?

    And aret you sure that the test is failing on the test steps for the Child Window? It looks like the step that is failing is over a hyperlinkbutton. Is there a hyperlinkbutton in the Child Window? Or does the hyperlinkbutton button launch the Child Window?

    Please reply back with more detail on the test sequence. I would assume you are clicking on something in the main page, then want to automate the child window. But the exact sequence would help, including where the hyperlinkbutton is located, on the main or child window.

    Kind regards,
    Nelson Sin
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Missing user
    Missing user avatar

    Posted 06 Jul 2010 Link to this post

    Hello again dileep,

    Just wanted to check back for you, please let us know if you have resolved this or are still encountering the problem.

    Best wishes,
    Nelson
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Back to Top