Unable to build iOS app

Thread is closed for posting
2 posts, 0 answers
  1. Nader
    Nader avatar
    43 posts
    Member since:
    Jun 2013

    Posted 31 Dec 2014 Link to this post


    I have created an AppBuilder project to test a plugin, and I cannot get AppBuilder to build my app.
    I tried building the app on XCode 6 and it all worked well.

    I do not know if there is something wrong with the configuration of my app or the build service, but I keep getting a "SR.net_http_client_execution_error" error.

    I should also note that the plugin I am using requires a framework that is quite large, and in order to upload it to my project, I had to host my project on Github and upload the plugin to Github, then I cloned the project in AppBuilder.

    I have attached the stack trace that I get in the AppBuilder log.

  2. Kaloyan
    Kaloyan avatar
    878 posts

    Posted 05 Jan 2015 Link to this post

    Hi Nader,

    Is it possible for you to provide us a Fiddler logs about the failure? To do so, you can follow the next steps:
    1. Download Fiddler from here and install it.
    2. Run Fiddler and go to Tools -> Fiddler Options.
    3. On the HTTPS page, verify that Capture HTTPS Connects is enabled.
    4. Verify that Decrypt HTTPS traffic is enabled with the ...from all processes option and minimize Fiddler to tray.
    5. Run your AppBuilder client and try to build the project again.
    6. In Fiddler, go to File -> Save -> All Sessions, save the archive to disk. This will produce a SAZ.
    7. Zip the .saz file and attach it in the ticket.

    Also, if you can share the exact plugin that you have imported, we might be able to reproduce the faulty behavior on our side.

    Thank you for the help in advance.


    Visit the Telerik Verified Plugins Marketplace and get the custom Cordova plugin you need, already tweaked to work seamlessly with AppBuilder.

Back to Top