Type or namespace name could not be found

5 posts, 0 answers
  1. Sivaraman
    Sivaraman avatar
    1 posts
    Member since:
    Jul 2012

    Posted 17 Dec 2012 Link to this post


    I am using the Terleik silverlight 4 Controls Version 2012.2 725 (Jul 25, 2012),  previously i have used "RadControls_for_Silverlight4_2012_2_0725_TRIAL_hotfix" dlls for silverlight 4 , it was working properly. Currently am using the dlls from "RadControls_for_Silverlight4_2012_2_0725_DEV_hotfix" (purchased). Am getting the below error for all the controls, can you tell me what i am missing?

    The type or namespace name 'RadComboBox' could not be found (are you missing a using directive or an assembly reference?)

    its giving error in "MainPage.g.i.cs"  and by doing resolve it is fixed temporarily. but while building same error am getting. Please help me to resolve this.
  2. Yoan
    Yoan avatar
    1128 posts

    Posted 17 Dec 2012 Link to this post

    Hello Sivaraman,

    Please follow these steps:

    1. Open the project and remove all Telerik's references.
    2. Save the project and close it.
    3. Open the project directory and delete "Bin" and "Obj" folders.
    4. Open the project and add the references.
    5. Build the project.

    Do you get the same errors again?

    You can also check this MSDN forum thread for a reference.

    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  3. hart
    hart avatar
    21 posts
    Member since:
    Jul 2008

    Posted 11 Jul 2013 Link to this post

    No, this did not work for me.  How did I get here?  These are the steps.

    Originally running VS2010 with Telerik Silverlight Controls (TSC).  Got a project from a customer, found out it was VS2012.  Installed VS2012 on my computer.  When opening the project in VS2012, found out I had no TSC(s).  Had to go to the Telerik website and relaunch the TSC installer.  Once TSC installer ran, I could then choose "Install TSC for Visual Studio 2012".  Install went fine.

    Now, re-opened the project in 2012 (had to delete and re-add TSC in the References section becase all 6 TSC(s) had yellow icons on them).  However, there were no TSC(s) in the toolbox.  To try and fix that, went to "Menu -> Telerik -> RadControls for Silverlight -> Launch Toolbox Configurator".  This was done to try and rebuild the TSC(s) into my toolbox.  VS2012 rebooted, however, still no TSC(s) in the toolbox, and I still get the "The type or namespace name Telerik could not be found" in all the CodeBehind software.

    Followed the suggestion in this thread to Clean and delete OBJ and BIN data -- no help.

  4. Yoan
    Yoan avatar
    1128 posts

    Posted 16 Jul 2013 Link to this post


    I can suggest you to check this and this help articles.

    If the problem still remains, may I ask you to send us small demo project in order to investigate the case.

    Thank you in advance.

    Learn what features your users use (or don't use) in your application. Know your audience. Target it better. Develop wisely.
    Sign up for Free application insights >>
  5. saeed
    saeed avatar
    1 posts
    Member since:
    Sep 2014

    Posted 14 Sep 2014 in reply to Yoan Link to this post

    its work
    my problem was solved.

Back to Top