This is a migrated thread and some comments may be shown as answers.

Tree Map cut off

2 Answers 44 Views
TreeMap and PivotMap
This is a migrated thread and some comments may be shown as answers.
jason
Top achievements
Rank 1
jason asked on 08 Dec 2011, 03:35 PM
I am using the tree map control and all is working good except that the bottom of it gets cut off.  I tried to put the tree map in a ScrollViewer but then the map does not display at all.  Is this a bug?  Is there a way for me to get scrolling capability so that I can see all of my data?  I have attached a pic of what it looks like cut off and what I get when using a scroll viewer.

2 Answers, 1 is accepted

Sort by
0
Ves
Telerik team
answered on 09 Dec 2011, 10:26 AM
Hi Jason,

The essential behavior of a treemap is to split the space into boxes, where the area of each box corresponds to the value being visualized. When values differ  by orders, it is natural to get tiny boxes next to larger ones. You can check this example for a possible way to extend the visualization with tooltips, so that you can display more details even for smaller items.

As for the ScrollViewer - RadTreeMap does not specify its own size, but it uses the size provided by its parent. When placed in a grid, RadTreeMap will be stretched to take the entire grid cell. When placed in a control, that measures its children to infinity, RadTreeMap will not be rendered. The ScrollViewer control measures its child to infinity in both directions, hence the behavior you have observed. In this case you need to provide explicit dimensions and you will be able to see the control.

Best regards,
Ves
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Thien
Top achievements
Rank 1
answered on 07 Nov 2012, 02:46 PM
I'm having the same issue that the RadTreeMap itemsource doesn't bind and it just renders an empty page where I expect it to render the image below like in the telerik example. I tried to copy the same code from Selection sample in RadTreeMap section in the telerik demo download, but not sure why the map is not loaded. Do you have any idea? Is it because I'm using the trial version or something else?
Tags
TreeMap and PivotMap
Asked by
jason
Top achievements
Rank 1
Answers by
Ves
Telerik team
Thien
Top achievements
Rank 1
Share this question
or