Test Studio Test Error?

3 posts, 0 answers
  1. CVue
    CVue avatar
    36 posts
    Member since:
    Mar 2015

    Posted 25 Aug 2015 Link to this post

    Running a test in VS plugin runs fine, but as soon as i load my project into test studio standalone and try to run the same test, i get this error:


    '8/25/2015 4:21:20 PM' - Executing test: 'thetest'
    '8/25/2015 4:21:20 PM' - Using .Net Runtime version: '4.0.30319.42000' for test execution. Build version is '2015.2.723.0'.
    '8/25/2015 4:21:20 PM' - Starting execution....
    '8/25/2015 4:21:21 PM' - Detected custom code in test. Locating test assembly: ​test.dll.
    '8/25/2015 4:21:21 PM' - Assembly Found: C:\test.dll
    '8/25/2015 4:21:21 PM' - Loading code class: ''.
    '8/25/2015 4:21:21 PM' - Failure detected during execution. Details:
    '8/25/2015 4:21:21 PM'
       at System.Reflection.RuntimeAssembly.GetType(RuntimeAssembly assembly, String name, Boolean throwOnError, Boolean ignoreCase, ObjectHandleOnStack type)
       at System.Reflection.RuntimeAssembly.GetType(String name, Boolean throwOnError, Boolean ignoreCase)
       at System.Reflection.Assembly.GetType(String name)
       at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.EnsureTypeExists(Assembly assm, String typeName)
       at ArtOfTest.WebAii.Design.Execution.ExecutionUtils.CreateCodedTestInstance(Test test, TestResult result, String binariesFolder)
       at ArtOfTest.WebAii.Design.Execution.ExecutionEngine.InternalExecuteTest(Test test, TestResult initializationResult)
       at ArtOfTest.WebAii.Design.Execution.TestExecuteProxy.ExecuteTest(ExecuteTestCommand command)
    '8/25/2015 4:21:21 PM' - Test completed!- System.ArgumentException: String cannot have zero length.​

  2. Ivaylo
    Ivaylo avatar
    775 posts

    Posted 28 Aug 2015 Link to this post

    Hello Cher,

    Could you please provide us with your project so we can try reproducing this behavior on our end?

    With the project I am using I am not able to get a reliable repro.

    Please note that if you are going to submit your project you need to open a ticket where all the provided information remains private.

    Quickly become an expert in Test Studio, check out our new training sessions!
    Test Studio Trainings
  3. Pieter
    Pieter avatar
    8 posts
    Member since:
    Jul 2015

    Posted 02 Oct 2015 in reply to Ivaylo Link to this post

    Hi CVue and Ivaylo,

     Hope you are well, and hope you resolved this issue by now, I ran into this issue yesterday where my tests would not compile/ be able to run due to the same error CVue is getting.

    So if anyone ever finds this post here is what I did to resolve this.

    Just try to re-add the reference to the ArtOfTest.webaii.dll.  While debugging I noticed that even tho the reference was there, it was not picking it up properly, now I do not know if this is a general Reference Issue form VS or if it is a telerik test studio Issue but re-adding the reference resolved my error.

    I hope this helps to whomever gets this error.


Back to Top