This is a migrated thread and some comments may be shown as answers.

Test Studio and Testing Framework

3 Answers 22 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Ewin
Top achievements
Rank 1
Ewin asked on 21 Aug 2013, 08:29 PM
Hello,
I am trying to do something simple like trying to the sample webaii test to launch its browser and complete its test by going to wikipedia and type in test studio and click go and confirm that it appears.

So from what I am experiencing, I have my work computer that has Test Studio on it and I used the sample test on it.  When I have it run, it rans completely fine as expected.

But on my home computer and a virtual machine, (Windows 8 with Visual Studio Professional) when the test starts to launchnewbrowser(), it hangs there and does nothing until it gets the timeoutexception. 

Is this happening to anyone else?

3 Answers, 1 is accepted

Sort by
0
Cody
Telerik team
answered on 21 Aug 2013, 09:36 PM
Hi Ewin,

I realize this is not obvious, but please try launching Visual Studio "as administrator". Our VS plug-in requires administrator level access before Windows will allow it to hook into the browser in order to control it. Unfortunately Windows won't tell us whether or not VS is running at the required level. It will simply silently block our attempts to connect to the browser.

Regards,
Cody
Telerik
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
0
Ewin
Top achievements
Rank 1
answered on 21 Aug 2013, 09:43 PM
Man, something so simple fixed the problem. 

Thanks. 
0
Cody
Telerik team
answered on 22 Aug 2013, 12:13 AM
Hello Ewin,

Thank you for the update and glad I could assist!

Regards,
Cody
Telerik
Quickly become an expert in Test Studio, check out our new training sessions!
Test Studio Trainings
Tags
General Discussions
Asked by
Ewin
Top achievements
Rank 1
Answers by
Cody
Telerik team
Ewin
Top achievements
Rank 1
Share this question
or