This is a migrated thread and some comments may be shown as answers.
Telerik OpenAccess ORM : No enhanced assembly has been found for meta-data construction
41 Answers 1802 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Amit Hiremath
Top achievements
Rank 1
Amit Hiremath asked on 30 Apr 2009, 09:36 AM

i have downloaded , mvc-forum applicatoin , and managed to compile and run it with proper Telerik.OpenAccess and Telerik.OpenAccess.Query Assemblies versions [Version=2009.1.311.1].

whenever i run the application, i get following error,

Telerik.OpenAccess: No enhanced assembly has been found for meta-data construction. This may be caused by a missing app.config file (use app.config as embedded resource then) or by an insufficient references section in the configuration file (add the referenced enhanced assemblies there too) or by a wrong enhancement setting; please check your configuration.

 

 

The error is coming at red line.

 

 

ModelObjectScopeProvider class

 

static public IObjectScope GetNewObjectScope()

            {

                  Database db = Database();

                  IObjectScope newScope = db.GetObjectScope();

                  return newScope;

            }

 

 

One strange thing I have noticed is that,  even if we debugged with F11 it does not go inside for red line.

 

please note that , i have installed

1] RadControls for ASPNET AJAX Q1 2009 [ Version=2009.1.311.1]
2] Telerik OpenAccess ORM [Version=2009.1.311.1]

41 Answers, 1 is accepted

Sort by
0
Alexander
Telerik team
answered on 01 May 2009, 10:11 AM
Hello Amit Hiremath,

I assume that you have updated all references to the OpenAccess assemblies installed on your machine. After that, please do Clean and Rebuild the whole solution. If the problem still persist, make sure that the Enhancing option is set to True for the Telerik.Mvc.Model project and rebuild that project again. The Enhancing option is available in the project's properties.

All the best,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Frank
Top achievements
Rank 1
answered on 02 Jun 2009, 11:33 PM
I have same error. I could only download version 2009.1.405.1, so I had to edit the version numbers in web.config.
Could you be more specific about how to add the Enhancing option? Would that be in the Telerik.Mvc.Model Settings?

CarmelFrank
0
Alexander
Telerik team
answered on 03 Jun 2009, 09:29 AM
Hello Frank,

First you have to remove the OpenAccess references from the three projects and add them again. This makes sure that you will be working with the latest installed assemblies. You have already done the next step - changing the version in the web.config file. After that it is very important to "Clean" the project before rebuilding. The Enhancing option is available in the project's properties. Just select the project from the solution explorer and press F4, the option must be enabled.

All the best,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
JoshKorn
Top achievements
Rank 1
answered on 04 Jun 2009, 08:36 PM
Alexander:

I have exactly the same problem.

I followed your advice, right up to the point of setting the Enhancing option. But I don't see any such option in the project properties for Telerik,Mvc.Model. However, when I look at the Telerik.Mvc.Model.csproj file with Notepad, I can see the settings:

  <ProjectExtensions>
    <VisualStudio>
      <UserProperties OpenAccess_EnhancementOutputLevel="1" OpenAccess_UpdateDatabase="False"
                   OpenAccess_Enhancing="True" OpenAccess_ConnectionId="" OpenAccess_ConfigFile="App.config" />
    </VisualStudio>
  </ProjectExtensions>

... which seems to indicate that Enhancing is set correctly. Additionally, I checked for an app.config file and found one right in the Telerik.Mvc.Model folder itself.

Unfortunately, this means that I don't know what to do next ... what do you suggest?

Josh


Thanks
Josh
0
Frank
Top achievements
Rank 1
answered on 04 Jun 2009, 08:53 PM
Josh,

Take another look at the last line of the post previous to yours:
Just select the project from the solution explorer and press F4.

I found that the option was already set.

Frank

P.S. A tip of the hat to the Telerik support crew for their diligent monitoring of these forums and prompt responses.
0
JoshKorn
Top achievements
Rank 1
answered on 04 Jun 2009, 08:59 PM
Frank;

Thanks, been there, done that, but it didn't do anything for me. It only shows the Project File and Project Folder properties, and in any case, the .csproj file itself shows that the magic value is already set the right way.

Josh
0
Alexander
Telerik team
answered on 05 Jun 2009, 10:02 AM
Hello Josh,

This is really weird, I tried downloading and running the demo on several machines and did not get any problems, the only thing I had to do was to change the references. Obviously our Enhancer tool fails to enhance the project. Do you experience such problems with other OpenAccess enabled projects? If only this application is problematic, could you tell me the exact version of OpenAccess ORM that you are using? I will provide you with an enhanced version of the demo.

Best wishes,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
JoshKorn
Top achievements
Rank 1
answered on 05 Jun 2009, 11:50 AM
Alexander:

The only reason I downloaded the OpenAccess ORM was because the mvc demo wouldn't build without it.
What I downloaded was the version that's available on the free download page -- 2009.1.405.1

Note that I also downloaded the RAD Controls too (and installed them before downloading and installing OpenAccess).

Josh
0
JoshKorn
Top achievements
Rank 1
answered on 05 Jun 2009, 01:50 PM
Alexander:

I got it to work by manually inserting a call to venhance in the post-build for Telerik.Mvc.Model:

             "C:\Program Files\Telerik\OpenAccess ORM\sdk\venhance" -assembly:Telerik.Mvc.Model.dll

This should be a sufficient workaround, since right now I'm just trying to run the demo and study the demo mvc code.

Thanks very much.
Josh
0
Alexander
Telerik team
answered on 05 Jun 2009, 04:22 PM
Hello Josh,

I am glad that you found a solution. I was just about to send you a compiled version, I did not want to bother you with manual operations with the enhancer. If you have any further questions or problems regarding our products, please do not hesitate to contact us.

Best wishes,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Keith LeBeau
Top achievements
Rank 1
answered on 24 Jun 2009, 08:29 PM
Just an FYI that we ran into the exact same problem and I think I know the issue that people are having. Up until this point (keep in mind, many years now that we've used your products), we've never had any need to install your Visual Studio Extensions package. The EnhancementOutput option is nowhere to be found until you've done so, and I couldn't find anywhere related to the MVC project that stated it was a requirement. After installing the Extensions package, everything came together.
0
Alexander
Telerik team
answered on 29 Jun 2009, 01:04 PM
Hi Keith LeBeau,

I do not really think this is the problem. The Visual Studio Extensions package is related to the RadControls for ASP.NET AJAX toolkit and it is not required for using OpenAccess ORM. It seems more like a problem with the installation of the OpenAccess addin for Visual Studio. Without this addin, OpenAccess cannot enhance projects and the specific OpenAccess menus and properties are not available. You can check if the addin is running from the Tools -> Add-in Manager menu of Visual Studio. If it is not there, reinstalling OpenAccess ORM may help.

Regards,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
Michal Ogluszka
Top achievements
Rank 1
answered on 06 Jul 2009, 02:21 PM
Hi,

 I have the same problem. On my computer everything is fine, but after deploying the project error is shown. I think I don't have to say that installing Telerik ORM on client computer is not an option...


Greetings
M
0
Keith LeBeau
Top achievements
Rank 1
answered on 06 Jul 2009, 03:36 PM
I can confirm again that installing only OpenAccess ORM does *not* enhance the projects for us. The VS Extensions package was required to get this to work.
0
Alexander
Telerik team
answered on 07 Jul 2009, 04:46 PM
Hello,

Let me summarize what to do if you get this exception. It pops up when the OpenAccess enhancer has not been called or did not succeed to enhance the compiled assembly. So, there are three possible ways to run the VEnhance program:
  • Automatically (default), using our Visual Studio integration (the OpenAccess ORM add-in for VS). The Enhancing option of the project should be set to True.
  • Using MsBuild integration (please read this help topic)
  • Manually, after the assembly is built (more details in this topic)
The VEnhance.exe tool is installed with Telerik OpenAccess ORM under the sdk/ directory.
Please, if the first approach does not work for you (probably there is a problem with the add-in), use any of the other two methods to enhance the project.

Kind regards,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Check out the tips for optimizing your support resource searches.
0
krishna surapaneni
Top achievements
Rank 2
answered on 14 Aug 2009, 03:00 PM
Hi all,

i have downloaded sales dashboard application, and i have installed Telerik OpenAccess ORM,

here i am getting an error like

"Telerik.OpenAccess: No enhanced assembly has been found for meta-data construction. This may be caused by a missing app.config file (use app.config as embedded resource then) or by an insufficient references section in the configuration file (add the referenced enhanced assemblies there too) or by a wrong enhancement setting; please check your configuration."

Even after applying all the solutions i did not get the result.

if there is any other possible ways to solve this problem..., kindly inform me...

Thanks & Regards,
Krishna.
0
krishna surapaneni
Top achievements
Rank 2
answered on 17 Aug 2009, 07:23 AM

Thanks to all,

I tried it again and I got succeeded. And now my application is working fine…

Thank you once again...

________________________________
Thanks & Regards,

Krishna

0
Tom de Koning
Top achievements
Rank 1
answered on 21 Sep 2009, 05:13 PM
The good: google pointed me to this page.
The bad: it does not state how to solve it.

I downloaded the SL SalesDashboard demo. I can't open the SL solution as VS immediately crashes. The WPF solutions opens fine, but the OpenAccess references are missing. Easily fixed because they are contained in the zip.

I first change the startup project to be the Shell.Desktop project. Then when I try to run I get the "No enhanced assembly has been found for meta-data construction" error.

Now I would think that if this error has occurred before and people have stated that the enhancements option is not found when looking at the properties there would be some pointer about what to do / where to look.

I have done a rebuild all, but no success. Please provide some advice on how to get the demo running.
0
Keith LeBeau
Top achievements
Rank 1
answered on 21 Sep 2009, 05:33 PM
Install the Visual Studio Extensions package corresponding to the version of the Telerik RadControls that you are currently using. It can be found in the same downloads section as the RadControls. Telerik insisted this wasn't a necessary step, but that was the only way I ever got it to build right with the enhancements.
0
Tom de Koning
Top achievements
Rank 1
answered on 21 Sep 2009, 06:45 PM
Thanks for the reply. I have searched the OpenAccess, WPF & SIlverlight download sections... but can't seemt to find the Extension packages download. Would you have a direct link?
0
Keith LeBeau
Top achievements
Rank 1
answered on 21 Sep 2009, 06:53 PM
Now that I'm looking myself, it's not a separately downloadable package anymore that I can see. Perhaps it's in that bloated 180MB install? I'd give the full install a try and see if it adds it. If not, you're going to need to ask Telerik how you can get those extensions installed.
0
Keith LeBeau
Top achievements
Rank 1
answered on 21 Sep 2009, 06:56 PM
Digging a little further, I found the last build that has them if you go back through older versions is 2009.1.527. You could always try installing that package if the big 180MB install of the current version doesn't have it, but I am pretty sure that the extensions are specific to the Telerik build you're working with.
0
Tom de Koning
Top achievements
Rank 1
answered on 21 Sep 2009, 07:35 PM
Downloaded the installer for Silverlight but it does not seem to include the guidance extensions. Rather that installing an older package, I'll wait a bit for the Telerik support (having spent the night browsing / trying for a solution.

Thanks Tom
0
Alexander
Telerik team
answered on 22 Sep 2009, 01:33 PM
Hello Tom de Koning,

The VEnhance tool is distributed with Telerik OpenAccess ORM and it is required that you have it installed on the machine. You can use the Trial version as well. After this, please remove the OpenAccess references and add them again so they point to the installed assemblies (not those in the bin folder). Then the problem should disappear.

Best wishes,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Tom de Koning
Top achievements
Rank 1
answered on 22 Sep 2009, 05:36 PM
Thanks for the suggestions. I've downloaded the latest OpenAccess bits, referenced it from the GAC.

When I run the WPF project I get "You are running a trial version of RadControls for WPF.", and then the same error message. I'd love to continue in trial and error, but in all fairness, this is getting ridiculous especially considering this issue has troubled many people before I tried.

Could you provide a download link to a solution that does work?

0
Keith LeBeau
Top achievements
Rank 1
answered on 22 Sep 2009, 05:40 PM
I would try installing the VS Extensions package for the 2009.1.527 version. Maybe there won't be a version conflict. Telerik never believed me that I was only able to get it working once I installed that package, but it absolutely would not work until I did so. Just letting you know what worked for me when I had the same problem.
0
Alexander
Telerik team
answered on 23 Sep 2009, 12:17 PM
Hello Tom de Koning,

Can you see the Telerik -> OpenAccess menu in Visual Studio? If so, this means the VS Addin is working and the Enhancer will be called. Please make sure that:
 - The Telerik.SalesDashboard.Data project has the Enhancing property set to True.
 - There are no outdated assemblies in the bin directories of the projects. Just delete all .dll and .pdb files starting with Telerik.OpenAccess* and Telerik.SalesDashboard* from all bin directories. Then rebuild the solution.

If you do not have such menu, the OpenAccess Visual Studio Addin is not running. This might happen if you are using Visual Studio Express, which does not allow usage of addins.



All the best,
Alexander
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Varun Jain
Top achievements
Rank 1
answered on 01 Jun 2010, 02:53 PM
Hello,

I'm too getting the same problem. I have salesDashboard version 2010 Silverlight 4. What could be the reason for it? Pleae help.

I have OpenAccess ORM, Rad Controls for Silverlight and VS 2010 with SQL server 2008. Kindly help.

Thanks,
Varun Jain
0
Alexander
Telerik team
answered on 02 Jun 2010, 09:11 AM
Hi Varun Jain,

You did not mention which version of OpenAccess you are using but in order to run the SL4/VS2010 demo without changing anything you need to install version 2010.1.414.3 (the latest internal build we published before the Q1 Service pack 1). Just referencing the OpenAccess assemblies would not be enough to run the demo because the enhancer would not be available on the machine and you would get the "No enhanced assembly..." exception.
So please make sure you have this OpenAccess version installed, Clean and Rebuild the solution. Then if the problem remains, let us know so we can continue investigating the problem.

Kind regards,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Varun Jain
Top achievements
Rank 1
answered on 02 Jun 2010, 10:31 AM
Hi Alexander,

I am currently using OpenAccess  2010.1.414.3. Could you give me a step-by-step procedure how to install everything and what all I have to install, so that everything run's fine and I could know what is the actual procedure for it.

I even tried to deploy it on IIS 7 but was unable to figure out why it couldn't show me the data. I think so there is some WCF service configuration error. Better if you could help me out.

Thanks,
Varun Jain

0
Alexander
Telerik team
answered on 02 Jun 2010, 02:38 PM
Hi Varun Jain,

I just tested the Sales dashboard on one of our machines and below are the steps I did to get it running. I assume that Visual Studio 2010 and OpenAccess are already installed:
- Install Silverlight 4 Tools for Visual Studio;
- Unzip the demo archive and open the Silverlight solution;
- Make sure that the Enhancing property of the Telerik.SalesDashboard.Data project is set to True; To check this select the project in the Solution Explorer and press F4, then you should see the property. If you cannot see it there, probably the OpenAccess Addin is not loaded, this would explain the cause for the error. If it is there, continue with the next steps;
- Rebuild the projects in the following order:
1. Telerik.SalesDashboard.Data;
2. Telerik.SalesDashboard.Common;
3. All projects under the Silverlight/Modules folder;
4. Telerik.SalesDashboard.Shell;
- Set the Telerik.SalesDashboard.Web as startup project and the Telerik.SalesDashboard.ShellTestPage.aspx as startup page, then run the project;

Please follow these steps and see if any of them fails on your side;

Regards,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Varun Jain
Top achievements
Rank 1
answered on 03 Jun 2010, 11:14 AM
Hi Alexander,

Sorry to say, But i'm using Open Access version 2010.1.312.2. There is no such version like 2010.1.414.3. On Building the Data Project. It gives an error.

"Error 1 OpenAccess Error: Version mismatch: The assembly Telerik.SalesDashboard.Data, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null references the Telerik.OpenAccess runtime 2010.1.414.3. The Telerik.OpenAccess enhancer version is 2010.1.312.2. Please rebuild the assembly or use theTelerik.OpenAccess enhancer version 2010.1.414.3 D:\Varun Collection\Telerik.SalesDashboard_SL_2010_1_422_Dev\Telerik.SalesDashboard\Telerik.SalesDashboard.Data\obj\Debug\Telerik.SalesDashboard.Data.dll -1" 

Could you tell me what the problem could be. Do I have to install SQL Server? If yes, which version should I install.

During the installation of ORM, it usually ask for the sql server instance giving options 1. (LOCAL)  2. (LOCAL)\SQLEXPRESS. Which instance should I choose, having not installed SQL server, except for the one which is being installed along with Visual studio 2010.

Thanks and Regards,
Varun Jain
0
Alexander
Telerik team
answered on 04 Jun 2010, 11:57 AM
Hi Varun Jain,

In order to run the demo with version of OpenAccess different from 2010.1.414.3 (this is our latest internal build before the Q1 Service pack 1) you have to update the project references. First please delete the Binaries/OpenAccess.2010.1.414.3 folder that contains the old references. Then run the Check Settings wizard from the Telerik -> OpenAccess -> Configuration -> Check Settings menu. Click Check, then Fix and the references will be automatically updated to the installed version. When you are done rebuild the projects in the order I mentioned in my previous post.
The demo is configured to run on a local SqlServer with address (LOCAL)\SQLEXPRESS2008. The server installed with VS2010 should do the job, just please check if its name is different from SQLEXPRESS2008 and update this setting in the Web.config file of the Telerik.SalesDashboard.Web project if necessary.
Hope that helps.

Kind regards,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Varun Jain
Top achievements
Rank 1
answered on 04 Jun 2010, 12:10 PM
Hi,

Thanks for all the help. Everything is running fine.

Just wanted to ask. Can this Application be hosted on IIS 7 or not. If yes, what is the step-by-step procedure of hosting this app and WCF service too.

Thanks for all the help.
Varun Jain
0
Alexander
Telerik team
answered on 07 Jun 2010, 12:55 PM
Hello Varun Jain,

The project surely can be deployed. I do not know if your setup is similar to mine (Windows 7 64bit) but here are the steps I performed to get it working:
Make sure the project is working in Visual Studio. Copy the Telerik.SalesDashboard.Web folder to the C:\inetpub\wwwroot\ directory. It is important for the WCF service to live somewhere inside this directory. Copy the following OpenAccess assemblies to the bin folder:
- Telerik.OpenAccess.dll;
- Telerik.OpenAccess.Config.dll;
- Telerik.OpenAccess.Runtime.dll;
- Telerik.OpenAccess.Adonet2.dll;
- Telerik.OpenAccess.35.Extensions.dll;

Now you have to configure the web site. Open the IIS Manager and add a new Application pool with name SalesDashboard, set the target framework to 4.0 and the Managed pipeline mode to Classic. Then add a new web site with a proper name and select the SalesDashboard application pool to be used. Set the path to the demo's folder and choose port 8000. Now you should make sure that the folder permissions allow reading and executing the files underneath. Please also update the service configuration so it contains the proper deployment address:
<services>
      <service behaviorConfiguration="Telerik.SalesDashboard.Web.SalesDashboardServiceBehavior" name="Telerik.SalesDashboard.Web.SalesDashboardService">
        <endpoint address="" binding="basicHttpBinding" contract="Telerik.SalesDashboard.Web.SalesDashboardService" />
        <endpoint address="mex" binding="mexHttpBinding" contract="IMetadataExchange" />
        <host>
          <baseAddresses>
            <add baseAddress="http://localhost:8000/" />
          </baseAddresses>
        </host>
      </service>
    </services>

I do not know if this problem would occur on your machine but it turned out that I need to add a handler mapping for .svc files. While the web site is selected in the treeview on the left, open the Handler Mappings settings dialog and look for mapping names starting with svc-ISAPI. I had only two of them that point to the 2.0 asp assemblies and needed to add another for the 4.0 framework. If you do not have such mapping either, click on Add script map and enter the settings below, then save the mapping:
Request path: *.svc
Executable: C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll
Name: svc-ISAPI-4.0-32bit

This should be enough to run the web site, the last step is to configure the database settings. As I had some problems with the dynamic attachment of the NorthwindOA database I suggest you to manually attach it to your sql server via Management Studio (if it is not already there) and remove the <connectionParams>AttachDbFilename=|DataDirectory|\NORTHWND.MDF</connectionParams> node from web.config file. Then select the SalesDashboard application pool in the IIS Manager, open the Advanced settings dialog and change the Identity option to Local System. This way you will be able to log on to the database server with your windows credentials.

When the web site is up and running you can remove the unnecessary files (like project files and source code) from its folder.

Greetings,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Solutionwhere
Top achievements
Rank 1
answered on 10 Jun 2010, 03:12 PM
I'm not using a sample project, but rather a project another developer worked on.  I have OpenAccess ORM version 2009.2.701.5 installed.  When I run the project I get the error: Telerik.OpenAccess: No enhanced assembly has been found for meta-data construction.  I tried setting Enhancing = true but that caused the project not to build.  I'm thinking I didn't need to mess with that step because I have OpenAccess ORM installed locally.  What else can I do to resolve this error?

Thanks,
Tonya
0
Alexander
Telerik team
answered on 10 Jun 2010, 05:52 PM
Hi Tonya,

The Enhancing property should be definitely set to True. Maybe the problem is somewhere else. Could you please share with us what was the error you got while building the project?

Regards,
Alexander
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Solutionwhere
Top achievements
Rank 1
answered on 10 Jun 2010, 06:05 PM
Hi Alexander,

I posted about the error here: http://www.telerik.com/community/forums/orm/design-time/error-building-when-enhancing-is-turned-on.aspx

The error is: OpenAccess Error: Unable to create type 'SW.CW3.DAL.Accessory' : Could not load type 'SW.CW3.DAL.Floor' from assembly 'SW.CW3.DAL, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null'.

The project builds fine with Enhancing set to false.

Thanks,
Tonya



0
Jørn Topnes
Top achievements
Rank 1
answered on 23 Jun 2010, 07:06 PM
I just had the same problem with the current trialversion, but it seems fixed when I edited my orm.csproj in notepad, setting OpenAccess_UpdateDatabase="true" and OpenAccess_Enhancing="true" under the visualstudio settings. In vs2010 project properties, the optimize code remains unchecked though. It might be worth trying if everything else fails. -Jørn 
0
Daming
Top achievements
Rank 1
answered on 02 Jul 2010, 08:45 PM

please help.

I just installed the latest Silverlight 4 Tools for Visual Studio; and got the same error while running Dashboard demo code. (and I checked that I got OpenAccess.2010.1.414.3).

I can not see Enhancing property of the Telerik.SalesDashboard.Data project, as you mentioned that  probably the OpenAccess Addin is not loaded, how do I load the OpenAccess Addin?

Thx,

Flatliner

0
Alexander
Telerik team
answered on 06 Jul 2010, 02:44 PM
Hi Daming,

If you can see the OpenAccess submenu at the bottom of the project context menu in the Solution explorer, that means the addin is loaded properly and you should be able to see the Enhancing project property by pressing F4.
If you cannot see the menu there, you can try to enable it from the Tools -> Add-in manager dialog. If the addin is not listed there, please try to uninstall and install the product again. Hope that helps.

Greetings,
Alexander
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Data Access Free Edition
Asked by
Amit Hiremath
Top achievements
Rank 1
Answers by
Alexander
Telerik team
Frank
Top achievements
Rank 1
JoshKorn
Top achievements
Rank 1
Keith LeBeau
Top achievements
Rank 1
Michal Ogluszka
Top achievements
Rank 1
krishna surapaneni
Top achievements
Rank 2
Tom de Koning
Top achievements
Rank 1
Varun Jain
Top achievements
Rank 1
Solutionwhere
Top achievements
Rank 1
Jørn Topnes
Top achievements
Rank 1
Daming
Top achievements
Rank 1
Share this question
or