This is a migrated thread and some comments may be shown as answers.
Telerik.OpenAccess.MSSQLServer not found
16 Answers 250 Views
This is a migrated thread and some comments may be shown as answers.
This question is locked. New answers and comments are not allowed.
Ivan Stankovic
Top achievements
Rank 1
Ivan Stankovic asked on 08 Nov 2008, 03:39 PM
When trying to run the Telerik ORM wizard for reverse mapping you get the Could not load assembly 'Telerik.OpenAccess.MSSQLServer, that file also doesn't exist in the bin directory of the ORM.

16 Answers, 1 is accepted

Sort by
0
Aniket Braganza
Top achievements
Rank 2
answered on 08 Nov 2008, 05:26 PM
I am having a similar issue. Every time I try to connect to my SQL server using the Telerik ORM Wizard I get the following message. I think the ORM Wizard is not working correctly. I can connect to my without any problem using Management Studio as well as Visual Studio 2008's Server Explorer.

test connect with the following URL:
Backend=mssql;Server=THEFRONT;Database=AppStore;Driver=;Integrated Security=True;
The connection could not be established. The reason was:
No Server.
A database server on the computer 'THEFRONT' does not respond.
Please verify that a database server is running and reachable on that machine.

0
Jan Blessenohl
Telerik team
answered on 10 Nov 2008, 11:48 AM
Hello Aniket Braganza,

Do you use an instance name or different port? Is the server running on the same machine as your development environment? Can you test

localhost
(local)
.
.\sqlexpress
(local)\sqlexpress
.\sqlexpress

Additional you can switch on the tcp/ip protocol in the sql server management studio.

Kind regards,
Jan Blessenohl
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Danny Joe
Top achievements
Rank 1
answered on 17 Nov 2008, 06:04 PM
FWIW, I have the same problem. The OP wizard cannot connect to my local instance of SQL Server 2005 no matter what server name I tell it to use.

Backend=mssql;Server=(local);Database=[MyDatabaseName];Driver=;Integrated Security=True;
The connection could not be established. The reason was:
No Server.
A database server on the computer '(local)' does not respond.
Please verify that a database server is running and reachable on that machine.

I also tried localhost, the server instance name, etc. And also using a specific user. Nothing works.

I can connect just fine using all other tools and methods.

The server is running on the local dev machine. OA is utterly unable to communicate with it.
0
Thomas
Telerik team
answered on 17 Nov 2008, 06:34 PM
Hi Danny Joe,

OpenAccess uses TCP/IP transport by default. This needs two things:
  • The Server must be using TCP/IP to provide its services.
  • The Firewall must be properly configured.
Both things need to be checked; additionally, the server could use dynamic ports for TCP/IP, but OpenAccess connects to the standard port 1433 per default so you need to check that setting as well.

You can force OpenAccess to use shared memory communication too by specifying lpc:. as your server name. This will only work if you have the server installed on your machine.

Regards,
Thomas
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Danny Joe
Top achievements
Rank 1
answered on 17 Nov 2008, 06:44 PM
The server is configured with TCP/IP enabled and set to use port 1433. The firewall on the local machine is disabled. I will try the "lpc:" in the name, but why would this be necessary (as in, the only way) to get OA to connect?
0
Danny Joe
Top achievements
Rank 1
answered on 17 Nov 2008, 06:46 PM
BTW, when I use this as the server name, it works:

lpc:(LOCAL)
0
Thomas
Telerik team
answered on 18 Nov 2008, 02:17 PM
Hello Danny Joe,

we would really like to know why lpc: makes a difference for you. We tried here on our side but we found no way to reproduce that behavior. What is your exact OS version? Are you using SQL 2005 or SQLEXPRESS? Did you try with localhost as the server name as well? You said you checked that TCP/IP is used by the server with a fixed 1433 port and that the firewall is disabled. When we tried here, we still could connect via (local) to our server, so that is kind of mystery for us.

Best regards,
Thomas
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Danny Joe
Top achievements
Rank 1
answered on 19 Nov 2008, 03:33 AM
I'm running Vista 64-bit Ultimate Edition. I'm using SQL 2005, not SQLEXPRESS? I did try (local), localhost and the instance name, as well. Yes, i confirmed that TCP/IP is enabled with a fixed 1433 port and that the firewall is disabled. It just wouldn't connect until I prepended the lpc: string to the (local) name. No idea why.
0
Thomas
Telerik team
answered on 24 Nov 2008, 01:20 PM
Hello Danny Joe,

Which service pack are you using with SQL2005? What is the result of "select @@version" for that server?

Best wishes,
Thomas
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Danny Joe
Top achievements
Rank 1
answered on 24 Nov 2008, 04:29 PM
Here's what it reports:

Microsoft SQL Server 2005 - 9.00.3068.00 (X64)   Feb 26 2008 23:02:54   Copyright (c) 1988-2005 Microsoft Corporation  Developer Edition
(64-bit) on Windows NT 6.0 (Build 6001: Service Pack 1)

Danny
0
Thomas
Telerik team
answered on 24 Nov 2008, 06:18 PM
Hi Danny Joe,

OK, we finally found and fixed this nasty issue; thanks for answering all our questions. The next patch (scheduled for end of this week) will contain the necessary changes.

Greetings,
Thomas
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
sarah longman
Top achievements
Rank 1
answered on 09 Dec 2008, 08:45 AM
CANCELED
0
Dencil
Top achievements
Rank 1
answered on 30 Mar 2009, 11:06 AM
hi thomas,

is this issue fixed?
i downloaded the open access on 3rd Apr 2009("Telerik_OpenAccess_ORM_2008_3_1327_dev ").
but still i get the error what other friends in this post have mentoined.
i tried all the suggestions found in this post and also in internet.
i couldnt create a connection with sqlexpress but not on my local server.
where is the problem?

please advice.

kind regards,
dencil
0
PetarP
Telerik team
answered on 30 Mar 2009, 01:27 PM
Hello Dencil,
can you please download and install our newest version of open access ( Latest Version: 2009.1 311). Please do let us know if you face any further problems after installing the newest version.

Sincerely yours,
PetarP
the Telerik team

Check out Telerik Trainer , the state of the art learning tool for Telerik products.
0
Dencil
Top achievements
Rank 1
answered on 31 Mar 2009, 11:12 AM
hi telerik,

i downloaded and installed your newest version (Q12009) still the same problem exists.
as told before its connecting with a SQLExpress instance and not with local instance.

please advice.

thanks&regards,
dencil.
0
Thomas
Telerik team
answered on 02 Apr 2009, 02:54 PM
Hi Dencil,

we tried here but everything works fine here. There must be something in your configuration of the server that we don't have and which is blocking you.
If you connect to the server with the VS server explorer and open a database, which Connection String do you see in the properties window that you can open by right click on the database?

Sincerely yours,
Thomas
the Telerik team

Check out Telerik Trainer , the state of the art learning tool for Telerik products.
Tags
General Discussions
Asked by
Ivan Stankovic
Top achievements
Rank 1
Answers by
Aniket Braganza
Top achievements
Rank 2
Jan Blessenohl
Telerik team
Danny Joe
Top achievements
Rank 1
Thomas
Telerik team
sarah longman
Top achievements
Rank 1
Dencil
Top achievements
Rank 1
PetarP
Telerik team
Share this question
or