Team Pulse on Windows Server 2012?

Thread is closed for posting
5 posts, 0 answers
  1. James
    James avatar
    6 posts
    Member since:
    Oct 2012

    Posted 02 Jul 2012 Link to this post

    Has anyone gotten Team Pulse to work on Windows Server 2012?

    Everything seemed to go OK in the install phase. Fired up a browser and got this error after the login page:

    Exception Type: System.Reflection.TargetInvocationException
    Exception Message: An exception occurred during the operation, making the result invalid.  Check InnerException for exception details.
       at System.ComponentModel.AsyncCompletedEventArgs.RaiseExceptionIfNecessary()
       at TeamPulse.Client.AuthorizationService.GetUserLicenseInfoCompletedEventArgs.get_Result()
       at TeamPulse.Client.App.GetUserLicenseInfoCompleted(Object sender, GetUserLicenseInfoCompletedEventArgs e)
    (Inner Exception)
    Exception Type: System.ServiceModel.ProtocolException
    Exception Message: The content type text/html; charset=utf-8 of the response message does not match the content type of the binding (text/xml; charset=utf-8). If using a custom encoder, be sure that the IsContentTypeSupported method is implemented properly. The first 1024 bytes of the response were: '

    <!doctype html>
    <!--[if lt IE 7]> <html class="no-js ie6 oldie" lang="en"> <![endif]-->
    <!--[if IE 7]>    <html class="no-js ie7 oldie" lang="en"> <![endif]-->
    <!--[if IE 8]>    <html class="no-js ie8 oldie" lang="en"> <![endif]-->
    <!--[if gt IE 8]><!-->
    <html class="no-js" lang="en">
    <head id="Head1" runat="server">
        <meta charset="utf-8" />
        <link href="/Content/Site.css" rel="stylesheet" type="text/css" />
        <meta name="viewport" content="width=device-width,initial-scale=1" />
        <div id="Wrapper" style="padding: 50px; background: #fff; border-radius: 3px; margin: 10px;">

    <div id="Body">
                An error occurred while processing your request
            <p>Try one of these options:</p>
                <li>Re-type the address</li>
                <li><a href="javascript: history.go(-1);">Go back to the previous page</a></li>

       at System.ServiceModel.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at System.ServiceModel.Channels.ServiceChannel.EndCall(String action, Object[] outs, IAsyncResult result)
       at System.ServiceModel.ClientBase`1.ChannelBase`1.EndInvoke(String methodName, Object[] args, IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.TeamPulseAuthorizationServiceClientChannel.EndGetUserLicenseInfo(IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.TeamPulse.Client.AuthorizationService.ITeamPulseAuthorizationService.EndGetUserLicenseInfo(IAsyncResult result)
       at TeamPulse.Client.AuthorizationService.TeamPulseAuthorizationServiceClient.OnEndGetUserLicenseInfo(IAsyncResult result)
       at System.ServiceModel.ClientBase`1.OnAsyncCallCompleted(IAsyncResult result)

    Is there an issue with 2012 or did I miss a step somewhere?

  2. Jordan
    Jordan avatar
    123 posts

    Posted 03 Jul 2012 Link to this post

    Hello James,

    Thanks for the report. We didn't test TeamPulse on the Release Candidate of Server 2012. We are going to setup such machine and test it immediately. Can you send us the logs from the teampulse log folder (%ProgramFiles%\Telerik\TeamPulse\logs)?

    All the best,
    the Telerik team
  3. Jordan
    Jordan avatar
    123 posts

    Posted 04 Jul 2012 Link to this post

    Hello James,

     We investigate the problem with the Server 2012 and found what is causing it. It is the change in the default behavior in IIS 8. It doesn't add the WCF Services HTTP Activation by default. It seems that we don't make that check during the installation. We will investigate and try to fix it. Until we fix the automatic configuration you need to go and add enable form the Server 2012 Features HTTP Activation.

    the Telerik team
  4. Rach
    Rach avatar
    4 posts
    Member since:
    Oct 2012

    Posted 31 Aug 2012 Link to this post

    We are interested at this too, we have tried and TeamPulse still doesn't work after changing the configuration mentioned manually. I'm going to open a support ticket because we plan on changing to a Windows Server 2012 after the release the next week.
  5. Ryan
    Ryan avatar
    164 posts

    Posted 31 Aug 2012 Link to this post


    I have responded to the support ticket you submitted, if you have any more questions feel free to ask them. 

    All the best,
    the Telerik team
Back to Top