Solution Upgrade Wizard places upgrade files in user appdata only

Thread is closed for posting
2 posts, 0 answers
  1. AJ
    AJ avatar
    4 posts
    Member since:
    Jun 2011

    Posted 23 Jul 2012 Link to this post

    I have discovered that using the Solution Upgrade wizard, whilst easy to use, can create a difficult situation with multiple dlls in obscure directories and it does not update the registered copy of the dlls.

    I installed the Windows Phone 7 controls into a directory under my Program Files folder. I think this was the default.
    C:\Program Files\Telerik\RadControls for Windows Phone 7 Q1 2012\Binaries\WindowsPhone.

    In my solution I added a reference to Telerik.Windows.Core.dll and it showed as File version 2012.1.321.2040.
    All was well.

    Some time later I was notified of an upgrade to the toolset (via the Visual Studio extension also installed). I followed the dialogs and upgraded my projects in my solution. Again all was well. Up to this point I had been working exclusively in Visual Studio.

    I then decided to try out Blend and opened the same solution. This was when I first ran into problems.

    When trying to add a Telerik control to a page, The Assets/Controls showed two instances of Telerik RadControls for WIndows folders, only one of which contained the RadJumpList that I wanted to use. When I dragged that control onto the design surface, Blend would immediately crash completely.

    Finally after a couple of days of back tracking and testing this and that, I discovered the cause.

    My projects in VS had been upgraded to point to binaries that were now residing buried down in my personal AppData folders, the temporary and hidden ones that you do not normally see. These binaries were version 2012.2.629.2040.

    However when using VS, and using the Add References dialog, that list was showing only the old versions 2012.1.321.2040.
    This version also was what Blend was able to see. Blend was getting duplicate assembly references since my projects were pointing elsewhere.

    Once I had this worked out, I replaced the binaries in the original directory under C:\Program Files\Telerik\RadControls for Windows Phone 7 Q1 2012\Binaries\WindowsPhone (since this was where the registration of the dlls was pointing)  and lo, now all is well. The VS Add References dialog now shows the latest versions and Blend also sees the same files.

    I suggest that the Upgrade Wizard should be modified to either update the registration of the latest dlls, or replace the existing registrations.

  2. Petar
    Petar avatar
    219 posts

    Posted 24 Jul 2012 Link to this post


    Thank you for contacting us.

    Indeed this is a known issue. We tried to implement update of the assemblies registration as part of the Upgrade Wizard but we encountered a problem. The problem is that the Upgrade Wizard not always has access to the registry since it is located under HKEY_LOCAL_MACHINE. We wanted to move the registration under HKEY_CURRENT_USER as we did for other products but it appeared that Visual Studio doesn't use this registry for Windows Phone projects.

    Replacing assemblies in the installation directory works but it is not recommended because it can cause installation issues later.

    What I suggest is to use the msi installation package when updating to the latest version of the RadControls.

    I hope the information provided clarifies the scenario. If you have any further questions don't hesitate to write us again.

    Kind regards,
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

Back to Top