Silverlight update from 1116 to 1220 Error- 'Cannot load file or assembly'

8 posts, 0 answers
  1. Steve
    Steve avatar
    8 posts
    Member since:
    Oct 2011

    Posted 18 Jan 2012 Link to this post

    Hi Telerik Team,

    We have started using the Silverlight Telerik controls and started with version 2011.1.1116, we updated to 2011.3.1220.1040 and now our controls do not show up? Only this message -

    "Could not load file or assembly 'Telerik.Windows.Controls, Version=2011.3.1220.1040, Culture=neutral, PublicKeyToken=5803cfa389c90ce7' or one of its dependencies. 
    The requested assembly version conflicts with what is already bound in the app domain or specified in the manifest. (Exception from HRESULT: 0x80131053)"

    We are using the Silverlight controls in Lightswitch and so far have had no issues, until the update? I have searched the Forums and see references to remove the existing version from the GAC (there was none). I have made sure that the references in the Custom Control and LS project are the exact same? Any ideas what would cause a conflict?

  2. Erjan Gavalji
    Erjan Gavalji avatar
    1455 posts

    Posted 18 Jan 2012 Link to this post

    Hi SD,

    Did you rebuild the LightSwitch application? Could it be that the application was alive while you deployed it to the web server? Or, could it be that for some reason the update to the web server did not happen properly, e.g. the XAP file did not contain the newly setup assemblies?

    Kind regards,
    Erjan Gavalji
    the Telerik team

    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

  3. Steve
    Steve avatar
    8 posts
    Member since:
    Oct 2011

    Posted 18 Jan 2012 Link to this post

    I have done a complete Rebuild and also a Clean then Build and watched the files in the bin disappear and regenerate, so I know the files are being updated. Also, I am actually running in Debug on my machine (not deployed yet) and everything runs fine except when navigating to the screen that has the control? 

    The control has been removed and re-added to no avail...
  4. Steve
    Steve avatar
    8 posts
    Member since:
    Oct 2011

    Posted 18 Jan 2012 Link to this post

    Found the Fix...

    In the LightSwitch project, after showing and un-hiding all the folders we found that even though the references in the Client project were correct. The references in the 'ClientGenerated' needed to be updated. 

    Looks like it was more of a LightSwitch problem than Telerik, however, this is one of those things to beware of when updating....

    thanks for the quick response :)
  5. Sponge
    Sponge avatar
    6 posts
    Member since:
    Jul 2012

    Posted 01 Aug 2012 Link to this post

    I had the exact same problem but I was upgrading from Q3 2011 version to Q2 2012.

    I'll try steve's solution.. I really hope it'll work.
  6. Aylin
    Aylin avatar
    75 posts

    Posted 03 Aug 2012 Link to this post

    Hi Sponge,

    I hope the solution provided by Steve will help you resolve the issue at your side.

    VSXTeam Aylin
    the Telerik team

    Explore the entire Telerik portfolio by downloading Telerik DevCraft Ultimate.

  7. Ser
    Ser avatar
    4 posts
    Member since:
    Aug 2012

    Posted 03 Aug 2012 Link to this post


    Im trying to make a calendar with Lightswitch. I get no error when in debug mode but when i change project to release it gives alot of errors.

    i got this a lot of warnings like this:
    Warning 1 The primary reference "Telerik.Windows.Controls" could not be resolved because it has an indirect dependency on the .NET Framework assembly "mscorlib, Version=, Culture=neutral, PublicKeyToken=7cec85d7bea7798e" which has a higher version "" than the version "" in the current target framework. ClientGenerated

    and errors like this:
    Error 106 The type or namespace name 'Appointment' could not be found (are you missing a using directive or an assembly reference?) C:\Users\....\Client\RadScheduleViewControl.xaml.cs 21 21 Client

    i deleted
    Telerik.Windows.Controls.ScheduleView; and readded ro client and clientgenarated (Tried 2012 Q1 and also 2012 Q2 ref.)

    when i hit f5 it removes suddenly (RadScheduleViewControl.xaml.cs)

    using Telerik.Windows.Controls;
    using Telerik.Windows.Input;
    using Telerik.Windows.Controls.Navigation;
    using Telerik.Windows.Controls.ScheduleView;

    and i got alot of errors like below

    i downloaded a few RadScheduleViewControl examples for lightswitch from telerik, i didnt make any change and it doesnt work like my project i got alot of errors related to refs.

    I tried to correct this problem and read all of but no solution for me...

Back to Top