This is a migrated thread and some comments may be shown as answers.

Silverlight 5 compilable?

24 Answers 465 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
SHANG JYH
Top achievements
Rank 1
SHANG JYH asked on 26 Oct 2011, 08:32 PM
Does this beta support silverlight 5 RC?

24 Answers, 1 is accepted

Sort by
0
Vlad
Telerik team
answered on 27 Oct 2011, 07:20 AM
Hello,

 Indeed Silverlight 5 is supported however our beta binaries are not native Silverlight 5 binaries. We will provide native Silverlight 5 after the official release of Silverlight 5.

Regards,
Vlad
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
smartpcr
Top achievements
Rank 1
answered on 09 Dec 2011, 09:17 PM
now that silverlight 5 is released, when are you planning to release SL5 compatible build
0
AvgurD
Top achievements
Rank 1
answered on 11 Dec 2011, 02:23 PM
+1
0
Sebastian Talamoni
Top achievements
Rank 1
answered on 11 Dec 2011, 04:43 PM
+1
0
Walid
Top achievements
Rank 1
answered on 11 Dec 2011, 05:35 PM
+1
0
HDC
Top achievements
Rank 1
answered on 12 Dec 2011, 07:57 AM
+1
0
Heli
Top achievements
Rank 1
answered on 12 Dec 2011, 08:14 AM
+1
0
Vlad
Telerik team
answered on 12 Dec 2011, 08:15 AM
Hi guys,

 While our current binaries are fully compatible with Silverlight 5 indeed we plan to release native Silverlight 5 binaries with our upcoming service pack after a week.

All the best,
Vlad
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Geir-Tore
Top achievements
Rank 1
answered on 12 Dec 2011, 02:37 PM
+1

Can you verify that RadPaneGroup/RadPane (2011.3.1116.1040 is latest Q3, right?) works with Silverlight 5? I have some weird issues here while upgrading our solution from Silverlight 4 to Silverlight 5 where the headers on pinned RadPanes is not displayed.
0
Vlad
Telerik team
answered on 12 Dec 2011, 02:49 PM
Hello,

 Indeed this version is our Q3 2011. Can you replicate the problem on our demos

Kind regards,
Vlad
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Heiko Görig
Top achievements
Rank 1
answered on 12 Dec 2011, 02:52 PM
I'm getting the following exception when using the RadRichTextBox in a Silverlight 5 project with the latest internal RadControls build:

The file or assembly System.ComponentModel.Composition, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 or one of its dependencies. The system cannot find the file specified.

Stacktrace: Telerik.Windows.Documents.UI.Extensibility.RadCompositionInitializer..cctor()
0
Trude
Top achievements
Rank 2
answered on 12 Dec 2011, 02:55 PM
"The file or assembly System.ComponentModel.Composition, Version=2.0.5.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35 or one of its dependencies. The system cannot find the file specified."

Update your project references to include the file System.ComponentModel.Composition.
0
Heiko Görig
Top achievements
Rank 1
answered on 12 Dec 2011, 03:08 PM
I only switched the Target Silverlight Version of an existing Silverlight Application to "Silverlight 5" and then the error occured. Besides that, the specified version of System.ComponentModel.Composition (2.0.5.0) is not part of the Silverlight 5 Runtime. And if I reference the current version of the assembly (5.0.5.0), a ReflectionTypeLoadException occurs.
0
Geir-Tore
Top achievements
Rank 1
answered on 12 Dec 2011, 03:41 PM
Hi Vlad,

I could not replicate it on the public demos. It seems to be something in your Metro theme which is broken, as I had to use that theme to get the issue.

I've uploaded a small sample of the issue here: http://dl.dropbox.com/u/360916/SilverlightApplication1.zip
0
Vlad
Telerik team
answered on 12 Dec 2011, 03:44 PM
Hello,

 Our demos are using Metro theme as well. We will review your application and we will let you know about our findings. 

Best wishes,
Vlad
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Geir-Tore
Top achievements
Rank 1
answered on 12 Dec 2011, 03:49 PM
Right, that's weird. It will be interesting to learn what you find then since our setup has worked fine in SL4
0
Geir-Tore
Top achievements
Rank 1
answered on 12 Dec 2011, 09:51 PM
Hi again,

I have now tried some other themes and they work fine so it is definitely something in the Metro-theme that is not working properly in SL5. My guess is that the new default value for RelativeSource.Mode (was TemplatedParent, is in SL5 FindAncestor) might be something to look into.
0
Trude
Top achievements
Rank 2
answered on 12 Dec 2011, 09:56 PM
"Besides that, the specified version of System.ComponentModel.Composition (2.0.5.0) is not part of the Silverlight 5 Runtime. And if I reference the current version of the assembly (5.0.5.0), a ReflectionTypeLoadException occurs."

I had the same error and it got resolved when I added the SL5 version (5.0.5.0). There must be something else in your code; it's not the same error anymore is it?
0
Marc Roussel
Top achievements
Rank 2
answered on 16 Dec 2011, 02:11 PM
I don't find the installation package under YOUR ACCOUNT as SL 5 is out since a few days now.  Does that means I can't compile my app in SL 5 yet ?  As when I try, the references aren't in the GAC
0
Vlad
Telerik team
answered on 16 Dec 2011, 02:16 PM
Hi,

 I've replied in this thread.

Kind regards,
Vlad
the Telerik team

Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get it now >>

0
Sistema PRI
Top achievements
Rank 1
answered on 16 Dec 2011, 06:47 PM
+1
0
smartpcr
Top achievements
Rank 1
answered on 21 Dec 2011, 04:53 PM
i've tried both v2011.3 and latest sp1, seems telerik.windows.controls.charting.dll and/or telerik.windows.controls.datavisualization.dll have different behavior than v2011.2... 

my solution works fine with v2011.2 and prism 4, but i am having problem if I
- switch dll from v2011.2 to v2011.3 (or sp1)
- change SL from v4 to SL v5

Please let me know if this is a known behavior (bug), thanks!
0
ben
Top achievements
Rank 1
answered on 21 Dec 2011, 04:57 PM
We solved a painful problem this morning using the a set of telerik Dlls built against SL5.

I managed to find them at http://www.telerik.com/account/your-products/trial-product-versions/trial-single-download.aspx?pmvid=2657&pid=571.

They are Silverlight 5 Dll's only, no tools or installers.

I've not got rid of the System.ComponentModel.Composition (2.0.5.0) errors and a whole host of others.

Hope this helps.
0
smartpcr
Top achievements
Rank 1
answered on 23 Dec 2011, 06:12 PM
it worked, thank you!
Tags
General Discussions
Asked by
SHANG JYH
Top achievements
Rank 1
Answers by
Vlad
Telerik team
smartpcr
Top achievements
Rank 1
AvgurD
Top achievements
Rank 1
Sebastian Talamoni
Top achievements
Rank 1
Walid
Top achievements
Rank 1
HDC
Top achievements
Rank 1
Heli
Top achievements
Rank 1
Geir-Tore
Top achievements
Rank 1
Heiko Görig
Top achievements
Rank 1
Trude
Top achievements
Rank 2
Marc Roussel
Top achievements
Rank 2
Sistema PRI
Top achievements
Rank 1
ben
Top achievements
Rank 1
Share this question
or