This is a migrated thread and some comments may be shown as answers.

Setting Step but not Min/MaxValue

1 Answer 41 Views
Chart
This is a migrated thread and some comments may be shown as answers.
ssawchenko
Top achievements
Rank 1
ssawchenko asked on 18 May 2010, 10:28 PM
Alrighty, me again, trying to bang out these questions before my trial disappears!

I was wondering if there is a way to set the Step for the Y Axis, while still in autorange mode?  I have some data, who's highest value is 120, but when using AutoRange the Y Axis contains up to value 200.  When the graph is large, this is ok, but I am putting the graph into a small location on the screen and that space at the top becomes very noticeable when made smaller.

I have set _RadChart.DefaultView.ChartArea.AxisY.ExtendDirection = AxisExtendDirection.None; (range is from 75-120) which appears to work when the graph is full size, but when I shrink the browser size, the Y Axis will show a lot of extra space (and the range becomes from 0 - 200).  This seems like a bug to me.

At first I thought that setting the Step would help, but after looking closer it looks like there is a bug in the extenddirection when shinking the size of the graph.

Any ideas, or will I need to manually force the min/max myself?




1 Answer, 1 is accepted

Sort by
0
Velin
Telerik team
answered on 21 May 2010, 12:16 PM
Hello shayla sawchenko,

I'm afraid you should use your custom range in order to overcome this behavior. You can not manually set value to the Step property while in AutoRange mode. Also you need all the three properties(MinValue, Step, MaxValue) in order to get a functional axis.

Kind regards,
Velin
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
Tags
Chart
Asked by
ssawchenko
Top achievements
Rank 1
Answers by
Velin
Telerik team
Share this question
or