Run on Device in Graphite

2 posts, 0 answers
  1. iggy
    iggy avatar
    15 posts
    Member since:
    Feb 2007

    Posted 06 Jun 2013 Link to this post

    I have an app that connects to a service that's on localhost (I've tried too)

    When I "Run on Device" with a device connected the app fails to connect to the service. I am behind the corporate firewall. I've tried IPv4 address, localhost and without luck.

    Could this be related to the corporate network configuration? If so, what changes need to be made?
  2. Jan-Dirk
    Jan-Dirk avatar
    327 posts
    Member since:
    Jun 2012

    Posted 07 Jun 2013 Link to this post

    You are probably running into a so called NAT loopback issue. I have a similar problem when I want to access webservices that run on a PC at home when I am connected with my wifi at home.

    Many DSL routers/modems prevent loopback connections as a security feature. This means that a machine on your local network (e.g. behind your DSL router/modem) cannot connect to a forward facing IP address (such as of a machine that it also on your local network. Connecting to the local IP address (such as of that same machine works fine.

    Is this on Android or iPhone/iPad? What I did was putting a proxy on one of my Windows machines. You can modify the hosts file on the machine so that a request to is forward to the ip of the PC running the web services.
Back to Top