Rows not showing up in RadGridView

2 posts, 0 answers
  1. pat
    pat avatar
    14 posts
    Member since:
    Aug 2011

    Posted 01 Sep 2011 Link to this post

    I have built an RIA services app that accesses a database table.

    1. This table has been made accessable to the Domain services class using an Entity Framework instance.

    2. The table has a primary key

    3. The table imports into the entity framework with no errors.

    4. I tried using the method that was built by DomainServices to access the table and I get this error

    "The remote server returned an error: NotFound."

    5. The other tables in the system all work fine.

    6. I tried building a custom method in the Domain service class and checked the rows that are returned in the Domain service class and it is getting the right rows in the Linq query.

    7. If I check the LoadOperation Entity count in the silverlight layer it is 0.

    8. This is followed by the error.

    "The remote server returned an error: NotFound."

    9. I built another RIA services app with just this table in it and I get the same error.

    10. Here is the code that is similar to code that I have used many times to access data in the silverlight layer.

    GLRDomainContext ctx = new GLRDomainContext();

    EntityQuery<TestSummary> query = ctx.GetTestSummariesBySummaryTypeOrderedQuery(1);

    LoadOperation<TestSummary> loadOp = ctx.Load(query);

    loadOp.Completed +=new EventHandler(loadOp_Completed);

    

    loadOp_Completed(object sender, EventArgs e)

    {

    LoadOperation<TestSummary> test = (LoadOperation<TestSummary>)sender;

    radGridView1.ItemsSource = test.Entities;

    }

    I have worked quite extensively with RIA services and it is very disconcerting that this can happen.

    Has anybody seen this behavior.

    Any clues or suggestions would be greatly appreciated as I have burned a lot of time on this.

    Cheers,

  2. Pavel Pavlov
    Admin
    Pavel Pavlov avatar
    2039 posts

    Posted 02 Sep 2011 Link to this post

    Hi Pat,

    I am a bit confused . Is the problem related to RadControls  ? I believe a RIA services dedicated  forum would be more helpful here.

    Greetings,
    Pavel Pavlov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

Back to Top